Diablo 2 Unable to identify version. Battle.net is unable to properly identify your application version

I recently installed my old D2 game as i wanted to try it out and be prepared for the D2 res and whenever i clicked on battlenet to connect i keep getting the error “Battle.net is unable to properly identify your application version” I have tried all the support tips but still it doesn’t work.

Please do help me. I have a windows 10.

Kind Regards

Same here, can´t update from 1.14b installer version via battle.net or manually either…
Tried all the support site tips too…

Same issue here too… currently on 1.14b aswell.

same here. let me know if you get it fixed ill do the same.

I’m having the same issue. Are the servers down?

anyone else fixed this yet?

Found a Fix guys, Change the Region to Asia. It’ll download the latest patch, then you can change it back. Happy Demon Slaying :slight_smile:

11 Likes

Thank you !!!

all it does is disconnect me from battlenet when I select asia

Hi all,

For more info and troubleshooting steps regarding this error, check out the support article here:

As sk3llingt0n mentioned as well it can sometimes help to change the region and back.

Additionally you’ll want to make sure you’ve installed the latest patch with the steps here:

your a boos how tf you know to do that stuck_out_tongue:

Hello!
I just had the same problem. But the recommendation that sk3llingt0n put in about changing the gateway to asia works! It will go on and update 1.14B to 1.14D after that you can change back to Europe or US east/west.

It seems Blizzard has turned off its FTP server with patches. They are available at different URL. You can download patch 1.14d from here (remove space after “https” because i can not insert links):
https ://download.blizzard.com/pub/diablo2exp/patches/PC/LODPatch_114d.exe

1 Like

worked for me - had to try about 5 times because I got a ‘disconnected from battle.net’ message but then it worked. Also might have helped to give the game permissions etc.

Same here. However, when I closed it and ran it with the recommended compatibility settings - it worked. Bit of a stretch but probably worth a shot.

You’re the MVP. <3 Thanks man!

Please do not bump older threads.