D2R Won't Run after pressing Play

Pressing Play → Blizzard app shows “Playing Now” and nothing happens.
The game appears in the Task Manager under Battle.net App, but nothing else happens.

Tried Scan and Repair with nothing changing, Restarted the PC, Checked for Video Drivers etc.

What happened in yesterday’s update?

6 Likes

I am seeing the same behavior. The update itself was painfully slow, and after that the game won’t launch.

2 Likes

Same her. I tried all the steps from the technical support page and still does not work. The game no longer starts after the latest patch.

As a workaround, disabling the NIC (network) before launching the game, and then re-enabling once the game has loaded, works for me.

Coincidentally, any patch downloads from Battle.net are incredibly slow (it took about 10 minutes to update the game over a 1GB fiber connection). It appears as though the game is trying to connect to a server, but is unable to.

2 Likes

Just tried it but unfortunately does not work for me.

Update: I uninstalled and reinstalled - still doesn’t work.

Same.
for more than a week, since last update.
I tried everything including fresh windows installation.
network reset, uninstall antivirus+firewall.
its on bnet side for sure.
why can’t offline be offline like the good old days?!
please fix this, I need to wait 20 minutes every time until the game launches.

edit: yeah, disabling the network adapter fix this as a workaround.

Same here, I can see the game running in ‘Task Manager’ but the game doesn’t open on desktop. Not sure if it helps but checking ‘Wait Chain’ shows red lines.

Deactivating network didn’t work for me.
Reinstalled B-net app - no results.
Restart - no results.
Same when trying through D2R.exe or B-net app.

EDIT: Deactivating network while game is “Running Now” or “Launching” does work but not immediately, had to wait few minutes before it worked

2 Likes

I’d like to bring up BattlePant’s network advice - it seems to work. It suggests that the executable is trying to do something online and the process just… hangs in the meanwhile.

I’m having the same problem. All my drivers and windows are up to date, my system is sufficient, but when I press play it says “playing now” and after a few seconds it appears as “play” again. I tried disconnecting the internet connection but the result is still the same. I cannot log into the game at all. I’ve never had this problem with other diablo games or any game on battle.net.

I deleted d2r and battle.net from my computer and repaired my windows with win11 iso. After that I installed battle.net and d2r back. Worked for me.