Challenge rift cache not received

Anybody there?

Hello everyone! Last night I completed the challenge rift in a little over 3 minutes but didn’t get the reward on the Pilar in town. I have the check mark as reward obtained, but never really did get it. It’s not on my inventory or stash either.

Has this happened to anyone before? Any possible solutions?

I play on switch

Bumping this one up. I just finished this week’s challenge and can’t find the reward this time either.

Am I doing something wrong? Where do I find the reward? How do I get it?

Please help, I don’t want to wait another week to upgrade my altar.

Does anybody even read this???

1 Like

Have the same problem. I completed on Nintendo. For fun am doing on ps4 but I was using my phone as Wi-Fi. I tried a few times. Failed. Left. For dinner. My ps4 disconnected from internet but Diablo up and running. When I came back I competed but was not online and didn’t know it.

I went and bought the necromancer pack and discovered I was OFFLINE when I competed the challenge. I don’t know if I received credit when I completed it offline.

I failed a couple times but the end screen said it was already Still cannot find reward.

Finally beat the the time again ONLINE THIS TIME but still no reward. I may have bugged it because of the online vs offline business?

Goddam it. It’s available to claim in my non seasonal characters