PTR keeps crashing

Yesterday played just fine. This morning I got an update, when I launch the game it crashes everytime at “logging in to diablo 4” screen. Anyone else with same issue?

1 Like

same here, was fine then it crashed, there was an update and now all it does is crash

so what I did was uninstall the game, delete PTR folder on my SSD, redownload the game, reboot the pc, and now it works. try it.

I played tonight. The game was rock solid. Then I enchanted and tempered the heck out of my gear and decided to head off and try the helltides and it crashed while it was opening the portal. Then trying to get back into the game, As soon as I select my character and click Start Game, it crashes. Last crash was 844622BD-F3F5-4B9A-9FF6-8DBA7B06DEDC
I did eventually get back into the game. I had been clicking “Start game” as soon as I had the option. But as soon as I gave it a couple seconds in the character select screen, clicking “Start game” was good. Getting back into the game, I still could not tp to the helltides. Had to ride my mount down there.

this happened to me too! is it fixed for you? if yes, how do you do it?

Same issue… First it crashed mostly when I teleported to different region but now it crashes during gameplay and even during startup.

Weirdly enough even the live version of Diablo 4 crashed while trying to boot up game now.

1 Like

yeah, I have many many crashes… and performace issues, on normal servers going just fine, here I hade to enabel frame generation :confused:

same here, especially open the teleport

1 Like

I had this very exact issue, too.
Mostly changing the location (like using town portal, waystones, exit dungeon feature from wheel, etc.) crashed my client.
Sometimes it could not even display character select screen.

Solution for me:
I disabled the limitation of FPS in cutscenes (can’t give exact naming due to the login issues right now).
Since then i did not experience a single crash.
I don’t know if this is jus a lucky coincedence for me or what might be the technical explaination for this behavior but it really worked for me.
Wishing you guys luck that it’ll help you as well.

Starting the game now worked.
Options → Graphics → Uncheck “Limit Cutscene FPS”
That’s what helped me.


It feels like this helped. Thank you.

same here, everytime i try to teleport to a different region after a while of playing - game crushes, however if i press “T” - doesn’t happen

Tried disabling FPS in cutscenes - doesn’t helped

*this all doesn’t happened in the seasons and eternal realm - only started in PTR.

solution: disabled Frame Generation and RayTracing - and it’s fixed

hopefully will help someone

Hey, everyone,
I had the same problem, but I did finally find the problem.
It was DLSS, also turn of Frame Generation if you have 4000 series.
After that, I had a strange error: FPS did not go higher than 107 FPS. It was a bit jittery, so I set it to 90 FPS caps.
No problems ever since! :slight_smile:

PS: Disabling FPS in cutscenes leads to a smoother transition from the loading screen and less jittering.

1 Like

This solution worked for me, ty!!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.