Version Mismatch


I’m getting the Version Mismatch Error with selected region message when I log into HOTS today all of a sudden. It was working fine yesterday but today after many attempts to fix the issue I’m still getting the same issue.
I’ve tried:

  • Manually checking for updates
  • Changing my region and launching the game
  • Logging out of the Launcher and logging back in
  • Reinstalling the game and then retrying the above steps
  • Deleting the interface folder

Not really sure what else to try, is there anything else I could do?


Hello Armageddon,

Which version does your game client show? The current one is

Kind regards

What’s your opinion?


Hi, i have the same problem, the way it works for me is that i have to reinstall the game with every update(i did it only twice), but i also have a problem that sometimes i have to wait a very long time for the client to start the download(and this is for every game in the blizzard app, except cod and destiny), I hope this was helpful.


Hello Kiemmaki,
I have the same problem as Armageddon, and yes my game shows version but it won’t let me do anything it just keeps going back to the version mismatch message.
I’m trying to complete the event going on and am almost out of time.
What else can I do?
How do i fix it?


Hello Shadowcortax,

Please try and close out of the Application and any other of our games and programs and delete your Cache and Tools folder.
Where is says deleted the Blizzard Entertainment folder, also delete the folder if you have one.

Kind regards

What’s your opinion?


yes it helped thanks


That is good to hear. Thanks a million for letting us know.

Kind regards

What’s your opinion?


had the same problem, thanks Kiemmaki, it worked


Good morning Parienchi,

Thanks a million for your feedback. Good to hear that it fixed it for you.

Kind regards

What’s your opinion?