Update stuck at initializing

For whatever reason Overwatch is stuck updating itself, it just says “Initializing…”
I’ve tried restarting Battle.net app completely, didn’t help. I’ve also tried pausing and resuming with no avail and double checked there’s enough space on SSDs.

Any ideas how to fix this?

Hi Kaotik!

There’s a few steps we can take to try and resolve that issue for you. :slight_smile:

Firstly, please fully close the Blizzard App, and any Blizzard games, and then uninstall the App as per this guide.

Next, please delete all the Blizzard App files, some of which may be left over after uninstallation, by following this guide.

Finally, please download and install the App again via this link.

Hopefully that will then resolve it for you!

Yours,

Arythwinn

1 Like

I did these steps since I was experiencing the same issue with MW2. Re installing the app it has been, “updating Battle.net Update Agent” and is stuck at 50% for about 10 minutes now. Any tips?

I have a similar issue. My fresh Battle.net installer cannot connect to the update service.
Here’s an excerpt from C:\ProgramData\Battle.net\Setup\bna_2\Logs\battle.net-setup.log

Downloader - {2520} INF: adding network address 37.244.28.30:1119 for server http://eu.patch.battle.net:1119

(The next two lines were repeated five times)
Downloader - {2520} ERR (d:\buildserver\bna-3\work-git\bootstrapper-repository\contrib\contrib\bnl_dl2\net\source\net\standardsocketnetwork.cpp, line 650): error receiving data from socket descriptor 1216:  [10054]
Network - {2520} ERR (d:\buildserver\bna-3\work-git\bootstrapper-repository\contrib\contrib\bnl_dl2\net\source\net\standardnetworkimpl.cpp, line 1087): failed to receive data from socket: NET_ERR_CONNECTION_RESET

Downloader - {2520} INF: fetch limit exceeded for download ID 1 (5/5 attempts)
Downloader - {2520} ERR (d:\buildserver\bna-3\work-git\bootstrapper-repository\contrib\contrib\bnl_dl2\downloader\source\downloader\standarddownloaderimpl.cpp, line 977): failing download ID 1: fetch limit exceeded
Download error - DOWNLOAD_ERR_NOT_AVAILABLE
Failed to download versions file

Both 37.244.28.30 and eu.patch.battle.net are pingable, although the latter is resolved and pinged over IPv6.

I’ve deleted everything before reinstalling Battle net.

UPDATE: That error was happened on 5G T-Mobile in Germany. It disappeared on the Vodafone cable connection.

Having the same problem. Reinstalled the app, deleted all files, nothing helps.

I’ve tried all of the steps listed on the support page and a few different other forums. NOTHING is working! This is so frustrating.

I’m getting exactly the same trying to install WOW and try it out on the lev 20 cap free offer.

It shows as 0% and initialising toggling between that and 2 figurs in brackets that keeps going back to initialising. Ive rebooted the computer and no joy

I guess i’ll subscribe to FFxiv instead

Getting this exact issue, but now on top of trying to figure that out I had made a ticket and the Gamemaster was not be able to figure out what it was and just acted like I deserved to be banned because my internet connection was bad and closed the ticket. I then made another ticket and the new gamemaster didn’t even look at ANY of the info (didnt even look to see that I wasnt banned) agreed with the first gamemaster and told me I deserved to be banned and closed that ticket without even looking at the original issue. WTF is even happening and can I be in trouble If I post those tickets for others to see how absolutely unproffesional they are being?

just to add, my connection is perfectly fine and haven’t had a single issue.