Crash when pressing arcade

3640CF45-6AD9-40A2-9254-D8277CDDC659
So my game crashes everytime i try to open arcade and i have tried updating drivers, restarting pc, repairing the game and crying in the corner but so far nothing works ;__;

So there are a couple of things that should help here based on the error report.

  1. Updating your windows, and making sure you have the latest updates from Microsoft

  2. Checking your Graphics Drivers are also the latest.

  3. Disable all Overlays, for example the Discord Overlay may be responsible for your crashes.

  4. Make sure you’ve done all the steps from here: battle.net/support/article/24032

Let us know if the problem persists after trying these.

C86667E2-BF19-442F-9150-D165BC2C517D
So jeah tried everything you said + reinstalling and rereinstalling but still nope nothing (but throo my friend i can play arcade with him but when i press the arcade button then it crashes)

I’m having this exact problem too, none of these fixes work for me either. :confused:

Ive had this problem for a week now, and the same as the other two people, it only occurs on pressing the arcade menu. Tried everything that was suggested and nothing works at all.

4D4330DE-05E8-4AE8-A876-E79768187982.

I also have this issue. I tried all the things suggested and I couldn’t get it to work

D9DF8C34-41F6-49DB-B2D4-458D459778B1

Edit: I switched the Region from Europe to America and now I can play Arcade

For this people with this issue, does changing the Region from Europe to Americas work for you?

I want to make sure it does before I escalate any details here for further investigation, as that would mean it’s a problem specifically with the European Arcade button.

Switching to America enables me to play arcade on America yes. But when i switch back to EU its the Same Problem, i have tried this a couple of times now to be sure and after switching back i have reinstall, updated things ect. This was yesterday for me.
Edit: Today after i could download the Newest Geforge Driver update i am now able to enter Arcade on EU.
Hope its the same for everyone Else.

After Switching to America it worked and now that new update came out in Geforge driver it worked perfectly in EU

It works for me now as well after installing the new GeForce driver.

Great thanks for also mentioning the new GeForce Driver fixes it, we can pass this on to our Tech team for further investigation.

If the issue should come back please let us know!