Galaxy Editor Login stuck at "Loading Blizzard Login page..."

My Galaxy Editor is stuck at “Loading the Blizzard login page…”

Steps to reproduce:

  1. Open the Blizzard Battle-net client
  2. Click “StarCraft II” then “Launch Editor”
  3. Once loaded, click File --> Managed Published…
  4. Click “Log In…”

In the window that pops up, the Blizzard Login Page is never loaded.

I am able to log in to my account in the Blizzard Battle-net client normally. I opened a support ticket about this but the support team was unable to resolve the problem.

What can I do to log into my account in the Galaxy Editor?

Based on just having encountered a slightly different issue, have you selected your proper region in the initial “Manage Published” window using the dropdown to the left of the “Log In” button? I was able to use said button but the Default/Auto setting definitely is broken for me on patch 4.9.3.

this doesnt appear to work for me Photoloss, is there a way to log in to avoid this ? or a work around ?

Bump I can’t log in to the editor the bar is faded.

Though this Topic is a few years old I could not find any other resolve for this. I have the same issue and it feels pointless to create maps when you can’t publish and test them.


  • When trying to connect, e.g. to open a map, a grey screen appears and says “Loading Blizzard login page…” and gets stuck there.

Troubleshooting I tried so far:

  • I tried “Default” Region as well as the region I am connected to in-game (EU).
  • I also tried to put my credentials in under “Pfreferences → Blizzard → Account”.
  • I reinstalled the game.
  • I started the Editor as Administrator.

Anyone having a solution? Or an idea?