Graphics device is not available at this time error

I updated my gfx drivers for GTX980 Nvidia chip and have started to receive the below error. I have reinstalled the game and rebooted my machine several times as suggested by the error but it still keeps coming up. I’ve installed to 2 different hard drives and the error still persists. Not sure what else to do…

"Graphics device is not available at this time. Please try starting StarCraft II again, or restarting your machine. if the problem persists, for more information consult our support website at http://blizzard.com/support."

3 Likes

Can you have a run through this guide please irrele. It should help.
https://support.blizzard.com/article/000018090

1 Like

Hi,
I have the same issue, but none of the offered solutions here worked for me.
Please help

1 Like

Same issue, none of the solutions offered are relevant to my issue.

I could play the game normally on my old card, but not since I got the new one. It’s an NVidia, so it should be supported, and it’s newer and better than the previous one.

Problem is, I can run the game normally if I uninstall and reinstall it, but after I restart my PC, this problem shows up again. Is there a way to fix this? Preferrably without having to fix it every time I wish to launch the game.

I also have the same occurance. It seems Starcraft gets tetchy with any machines with multiple graphics drivers.

I too have started to have this error, It seems to be tied to the Windows 10 Update that happened this week

[ Open Battle.net App > Click on SC2 > Options > Game Settings > Reset In-Game Options ]

This solved the issues for me

5 Likes

Resetting ingame options works

Hi There,
I updated my RTX drivers for the Nvidia RTX2070. Windows has made a update to… I have reinstalled the game and rebooted my machine several times as suggested by the error but it still keeps coming up.

Graphics device is not available at this time. Please try starting StarCraft II again, or restarting your machine. if the problem persists, for more information consult our support website at [http://blizzard.com/support]

Can you help me?

Resetting ingame options worked for me as well.