Maps won't load

Hello. I have a fresh install of SC2 that will not load any maps of any variety online. Any solutions?

Same here ! i can launch the game but there is many issue :
-My profile picture doesnt appears
-The Ranked button is greyished
-When I click the Unranked button it goes greyished and says “Not available while initializing game modes”
-I can’t joins a Lobby, the maps are loading for ever
-I can’t create a Lobby, no maps appears.

HEEEEEEELP !

Thx.

Hi there guys!

We have had some graphical issues with the latest SC2 patch but the major problems should have been bug fixed last Thursday (the 5th of December).

@Unforgiven: Has this fixed your problems?

@DeadRabbit: Sad to hear you’re still having some issues. Can you please try running Scan and Repair on the game (Options -> Scan and repair) and try updating your graphics drivers.

HI, I have the same errors just like you did. Just want to ask how can you got all the trouble fixed ?

HI, I got the same trouble now, as DeadRabbit had.
When I install on my HP omen laptop, SC2 work just fine.
But when I try to install on my PC, well, it doesn’t want to load the maps in melee or lobby. I tried all the things you have been listed such as update driver, reinstall it… so far, nothing work.
It will be wonderful if you can help me fix those trouble.

My spec is:
Core i3 3.1Ghz
32 GB Samsung Ram
240GB WD SSD
1TB SG HDD
MSI GTX 1660 6GB
MSI H97 gaming board

I have the same issue

DeadRabbit - did you find any solution? My friend and I have the exact same issue after a fresh install.

Blizzard - why are you not doing anything about this issue?

I’ve tried Options - scan & repair and I’ve updated my graphics driver on my nvidia 960m. Can you provide a download link to previous versions? Maybe that will solve the problem.

Any updates from Blizzard?
I have tried the following but custom melee maps still do not load:
-scan & repair
-updating graphics card
-disabling firewall
-opening ports
-switching regions
-using alternative devices (surface pro & laptop-nvdia 960m updated to latest graphic driver)
-change DNS to 8.8.8.8, 8.8.4.4

Same here . Is blizzard handling this issue ? or SC2 is dead ?

Today there have been some issues with Amazon’s internet infrastructure, this results in routing errors for me to twitch, reddit and probably others not attempted yet. If I change the DNS to googles or CISCO umbrella i can load those websites but maps under custom will not load. My default DNS status is OK though.

This is just unacceptable from a company as large as Blizzard, why is my offline maps list tied to whether I have a certain DNS or not? The ones provided to me by my ISP should be acceptable but they are rejected and the maps list will not load.
imgur y5UQup2

Here’s what I did to fix it

  • I quit out of SC2, battle.net
  • I removed these directories from a terminal (I’m on a mac):
rm -r ~/Library/Application\ Support/Blizzard
rm -r ~/Library/Application\ Support/Battle.net
rm -r /Users/Shared/Blizzard/
rm -r /Users/Shared/Battle.net/
  • then I started Battle.net and logged in again
  • then I got into SC2
  • then I changed my profile name from Flicker to BrianCunnie
  • then everything worked