Movie Audio Problem (Audio Italian)

Sorry for my bad English.
I ask the community for help, as the support apparently can’t do anything.
I use the Italian version, and in the options the option is selected to use the original audio, in Italian and not the remastered one.
I haven’t played starcraft for a long time, but I remember very well that in the first versions the audio of the videos was in Italian. Now after the last update or in some previous update, the audio is in English the remastered one, even if the option to have the original audio is set.
Now my only option, and to force the audio to the original graphics by pressing the F5 key. And while the video is playing, I press F5 again so that I switch back to remastered but keeping the audio in Italian.
I made a video to make you understand, as I switch from the audio in English to the Italian one: https://youtu.be/AkeWrnvJYTQ
How can I solve the problem, and have the audio in Italian, without having to press the F5 key every time?
is it possible to make a change to some file manually and correct this error? Thanks a lot!