After installing a new SSD on my computer and reinstalling Windows10 on it, I tried playing SC2 again. But this ERROR message keeps popping up whenever I try to play COOP mode. Everything else works fine.
I tried uninstalling and reinstalling on both new SSD and old HDD. Same ERROR every time.

What is this error anyways?
And how do I fix this?

Please help!

I too am having this same issue. CLIENT SIDE CACHE ERROR.

Me too, any known fixes for this? ive tried clean installation but still cannot play vs AI mode, but i can play Campaign just fine.

This error means the game can’t connect to the servers to download any missing in-game data.

We would, first of all, suggest trying the Basic Connection Troubleshooting steps. Should the problem continue then you can you please try the following steps:

  1. Press windows key + R > Type %programdata% > Click OK > Delete the and Blizzard Entertainment folders

  2. Press windows key + R > Type %appdata% > Click OK > Delete the folder

  3. Press windows key + R > Type %localappdata% > Click OK > Delete the and Blizzard Entertainment folders

Then make sure to run the App as administrator when you restart it (Right click the icon > Run as Admin).

Lastly try flushing your DNS.

If the issue persists, please upload your system files to and reply with the links to the files using the preformatted text option to encapsulate the links.

I am getting this on my OSX without any changes on hardware or software, only new thing is patch 5.0.5 and bought Dehaka commander.
Also why didn’t you write instructions for Mac users ?

Tried everything and it still gives me this error !!! I don’t want to reinstall +20GB while it seems it doesn’t resolves the issue.
Please help.

Me too… After the update yesterday, I can’t play 1v1 and coop mutation. Tried reinstalling but failed. Tried your solution and DNS flushing but still the problem persist.

it fixed when I party team up with a friend. It seems my internet is the culprit.

None of these fixes help, whatsoever.

I knwo where the Prblem is.
It exist three types of NAT types.
NAT-Type 1 / open for all
NAT-Type 2 / Moderate
NAT-Type 3 / Strikt
if you have NAT-Type 3 you can’t connect to some Server or Download some things.
If you have NAT-Type 2 you can use more than NAT-Type 3 but mot everything too.
But If you have NAT-Type 1 you can use everything.

You can “open” your WiFi with Ports. You can google: How to Open Ports at your Internet Provider.
if you have questions you can ask me. :smiley:

Hope i Helped you :wink:

Clientsidecache_read_bad_hash ???

Hi [ProfPlanlos], I did what Blizzard suggested but it is not working, so I guess you are right the issue is connected to my internet settings. In your post, you say one needs to open ports. Ok, but what ports? Cheers and thank’s for your help. Florian

Having the same problems currently. Tried the steps Blizzard provided, but to no avail. The error pops up when I try to download any maps.