Starcraft 2 crashes on launch

As soon as i try to launch starcraft 2 it gets an unexpected fatal error with the following error code: 50BCEDB4-991F-458B-912D-A99602C7FAEE.
I have tried reparing it, tried deleting folder in documents, tried terminating agent and removing folder from program data, tried uninstalling it and installing it again. windows is updated and gpu drivers are updated. background applications closed.

Pls help me with this issue.


I also think i have a similar issue . also instant crash, although I’m getting a 00000000-0000-0000-0000-000000000000 error . Saying “files in your StarCraft II installation are damaged”.
Im currently using windows 11 are you?

im not sure if i should make this a separate issue thread but will if need.

I’ve got similar issues – game crashes while loading right when the initial image is shown. There’s the following summary in the error logs:
<BlizzardError.Summary> Internal Error H $H t$WH P

Running Win11 Version 10.0.22631 Build 22631

When the game crashes the OS cursor speed is reset to default.

Similarly to the author of the post I’ve got up-to-date video drivers and tried reinstalling, also resetting the game settings to default and running with both displaymode=1 and 0 in Variables.txt

Nothing helped thus far. Any advise is much appreciated.

Hey all,

Are any of you using OneDrive? If so, OneDrive and SC2 aren’t compatible. See this article on how to unsync your Starcraft 2 folder (that is inside the Documents folder).

Thanks for the reply. I saw that issue in another thread, but OneDrive wasn’t signed in.

Still, I gave it a go – signed in and configured it to another drive and excluded Documents just in case. Nothing’s changed. Game still crashes with Internal Error.

I’m having the same issue on both Mac and PC. I click “Play” and nothing happens – not even a Game is Running message. Looks totally broken.

I’m having this problem and I’ve tried all the things everyone has stated weirdly enough SC1 is having a similar problem just a different code