Starcraft Remaster will not open

I just get a box pop up starting that “The application encountered an unexpected error”. uninstalled everything and reinstalled (battlenet and starcraft) but still the same.

No error codes, just that message - no idea if the “Send to Blizzard” option is working but here is the latest Report Id

7D1AB056-1C6A-4359-BAE2-3FC3B0E8FD60

2 Likes

Same here, the suggested steps from Blizzards tech support page do absolutely nothing. Apparently sending the report to Blizzard 80 times does absolutely nothing either.

The reports are not for receiving a reply but to gather technical information on the crash for any possible bug fixes on our side.

Do you have any of the Crash IDs Computer? We can look into this further with the ID of a crash you have sent to us already.

So mine opens up battlenet, refuses to load off cd, and forces me to load off battlenet.
Battlenet is logged in.
Game opens in separate window, tells me it can’t connect and that I need to play offline, so I click play offline.
Then it tells me in order to play offline I need to log in. Just take a second to think about that.
So I try to log in, it says battle net is temporarily down.

So here I am, with my old copies of wings of lib and heart of the swarm, and I can’t play them.

And the even stupider part, is try as I might, I can’t find the protoss version for sale on battlenet anyways. Like wtf? I thought it would be downloadable by now.

Our advice for installing the game is to download the Battle.net App from here: https://www.blizzard.com/download/

You can also head here and click on the Play for Free option: https://shop.battle.net/product/starcraft-ii

Once installed you simply then go to SC2 and install it through the App and not through the CDs.

As for buying Legacy of the Void, once you are able to get online you will have an option to buy it from the Campaign selection screen in-game, or you can buy it here: https://eu.shop.battle.net/en-us/product/starcraft-ii-campaign-collection?p=32192

The discount won’t show until you get to the checkout but you will be discounted for owning parts of the Campaign Collection already.

Whenever I launch SC Remastered on my MacBook Pro (M1 chip) the game just quits immediately. Apple silicon has been out for a while now so I’m not sure why the game fails to run.

hello can anyone help me, today i bought and install SC remastered from battle.net and when try to play its said the application encountered an unexpected error 09D90E09-BF19-4A97-8BE9-4DF83BABD1EF, i tried scan and repair it doesn’t work, i also tried uninstall and install few times but still having the same problem

BLIZZARD SUPPORT! NEED HELP!

Bought SC Remastered today. NOT LAUNCHING on Apple MacBook Air M1. MacOS 11.6.1
System Requirements clearly have no objections regarding M1 or modern MacOS versions.

Some part of the crash log below:

System Integrity Protection: enabled

Crashed Thread: 0 Dispatch queue: com.apple.main-thread

Exception Type: EXC_CRASH (SIGABRT)
Exception Codes: 0x0000000000000000, 0x0000000000000000
Exception Note: EXC_CORPSE_NOTIFY

Application Specific Information:
Assertion failed: (result == KERN_SUCCESS), function mac_exception_set_handler, file /Volumes/data/jenkins/workspace/starcraft_pipeline/Starcraft/build/package_cache/crashy/1.2.32/noarch/src/mac/ExceptionHandler.mm, line 1538.

__cxa_guard_acquire detected recursive initialization