Unexpected fatal error when launching SC2

Hi Every time I launch the game, the screen goes black for 2 seconds and came out again. I got an unexpected fatal error with the following error code.

I have have tried everything I can find on the form try to fix this. But still not working. updated my graphics driver, reinstalled battle net and SC2, tried hardware exceeds minimum requirements and ensured it is allowed through my firewall.
What else can I do ? I need some help .


It seems that there is an issue with your DirectX crashing here, from the crash reports it seems to be because your Graphics Card is no longer supported to run the game. You can try the following to see if it helps, but sadly we can’t offer any further support for your GPU:

  1. Press Windows + S, type “Xbox” in the dialogue box and open the application.
  2. Click on the Settings icon present at the bottom left side of the screen. Now select “Game DVR” from the list of tabs and uncheck the option ”Record game clips and screenshots using Game DVR”.

Depending on your version of windows this may be in another location:

  1. Press Windows + I to launch Settings. Click Gaming from the menu and then click on Captures from the left navigation bar.
  2. Uncheck the following options:
    • Record in the background while I’m playing a game
    • Record audio when I record a game.
  3. Restart your computer and launch StarCraft again.

You should also try adding a command line

  1. Open the Battle.ne App and navigate to Options > Game Settings > Additional Command Line arguments.
  2. Now type the following command in the dialogue box of StarCraft. Make sure that you also check the option Addition command line argument (exactly as written):
    • -Displaymode 0

I’m running a 3090 Ti with update drivers. Telling me I am out of date is like telling someone they aren’t ruining the economy. I know you guys have been monopolized and aren’t the company you were when I grew up with you… But please strive for a semblance of being competent. You get enough money to do it. Quit being a scummy company.

1 Like

Hello MrPirate,

I’m encountering the same problem, did you manage to fix it in the meantime?

I have a new rig and it shouldn’t be related to the technical specs. Might have something to do with the DirectX for me though, since it’s not the only game I’m having trouble with and the other one actually mentions DirectX in the error message.