Updated with solution: Incorrect version loading prevents login 5.0.2.81102

When trying to start SC2 the current live build is: 5.0.2.81102
When launching SC2 live: 5.0.2.81102 PTR is loaded instead. This prevents me from logging in.

When will the correct version load again so that we may play the game?

Solution:
As launcher keeps starting PTR version instead of Live, giving the Server Down to maintenance error. Uninstall the game from battlenet app. Install it again. Now the files that was incorrectly downloaded by blizzard app and replacing live with PTR files gets replaced with propper live files. After this SC2 works perfectly again.

Using the update/repair features does not resolve the issue, as the app compares to PTR version, and they are the same, and not the Live version.

I’m amazed that blizzard themselves hasn’t figured this out yet.