Can't use local keybinds

Same here for Finnish Keyboard Layout. I dont have English Layout installed but from what i can see the keys it changes to dont correspond to English layout § + ´ become / = [.
This is a 9.2 issue i would guess due to !quickcast

1 Like

Same issue here, Swedish / Scandinavian keyboard-layout here.

I press “§” when I try to keybind and it shows as " \ " (backslash) on the keybind.
And no I havent activated another keyboard-layout it is set to SWE when this happens.

Why is this suddenly happening in the new patch?

Any ETA on a fix for this?

Yeah its like in chat you can write normally § ÅÄÖ but when you go into the keybinding-interface its like the game thinks you’re using a American layout.

Have you reported it as a bug ingame? QA and the devs need to know about it to fix it. I suggest you all do so.

The bugreport interface points us to the forums, so we cannot report this by the in-game report-system.

No it doesn’t if you click the bug report button:

Click the red ?
Click Support
Click Submit feedback/bug report

This is an old picture but I think the button is still in the same place:

I have already reported the bug.

1 Like

Hopefully a lot of people will and it’ll get fixed soon.

In case it helps anyone:-

This does not help.

Seems the only way to fix is to make second keybind until they fix the issue

I have the same problem. I use a Swedish keyboard, and the buttons § ä ’ ¨å ´ + work fine in chat, such as /s och /g, but looks completely different when I open the keybind interface. ö still looks the same though… The solution suggested above didn’t change anything when I tried it.

1 Like

I have just found this in the Tech Forum from yesterday lunchtime - sadly they didn’t reply here too (the original post is from a blue but seems to have turned green when I quote it):

1 Like

Just popping in to add that as mentioned on the Technical Support forum, this is something that we’re aware of and investigating at this time!

For now, please try the workaround linked by Punyelf, as that may help with the issue until a fix can be pushed.

Since today I am having a problem with the circumflex key:
once I press the key nothing happens, if I press it a second time or any other key the circumflex appears + the other key I pressed.

I know this may sound weird, but I hope my description was accurate.
Feel free to ask for additional informations.

Kind regards

Try to just rebind it. Worked for my Gf who had the same problem.

1 Like

the issue is this problem is not only in wow but also everywhere else in windows

Do we have any updates on a potential patch/hotfix for this by Blizzard?

This is affecting every country that isnt US or UK as far as I see it.

I do hope this gets fixed soon, first time ever I don’t play new patch cuz cba clicking…

It’s really time to get this sorted now blizz… this is not ok that it takes this long time to get sorted!

1 Like

This is still not working. People outside US should also be able to use keybindings, seems like a pretty core issue