Game using too much menory?

Reporting in that I have this issue, too. Norma memory usage on my PC was 70%. Now it keeps climbing until after about 45 minutes of play the usage is over 95% and the game becomes unplayable due to the stuttering caused by the game trying to use my PC’s page file as extra RAM. I have 12gb of RAM. It should be enough to run the game and it was for the last six months.

1 Like

It’s since DF prepatch so don’t even think that they’ll fix that.

1 Like

As of the latest patch, there are certain moments and areas that feel like the zone starts doing a memory leak.

I wear headsets, and gradually while playing the new zone, I can slowly start to hear my computer ramp up in resources being used to the point I can loudly hear it after a while. I have to shut down the game to get it back to normal.

This is worrying, as none of DF has done this at all, my computer which was purchased in 2022 had been able to handle all of World of Warcraft as if it was nothing until that spike slowly ramps up from 10.2.

Luckily, we are nearing winter, had this memory leak occurred during summer, I fear it would fry most computers.


I recommend you folks do an asset repair and maybe turn off any addons (if any) and turn those back on one by one to see if the memory leak is either client or addon-related.

Yesterday I specifically raced for 6 hours in LC Classic, no problems with memory. I reinstalled DF, I’ll take a look now, but I don’t really hope that the reinstallation helped. And yes, there are many posts on US forums about this problem. I sympathize with everyone, we were unlucky.

1 Like

Have the exact same issue, game needs a restart every 30 minutes and task manager clearly showing WoW as the issue.


On the US forum somebody has marked using DX11 instead of 12 as a solution but that has nothing to do with it since I have never used DX12 - my card doesn’t even support DX12.

I’m glad I’m not alone with this problem. I hope that Blizzard will solve this problem as soon as possible because it is quite annoying.

1 Like

Same problem. Battlenet and WoW are installed on M2 disk, but Logs are locating on normal disk C. After 10.2 I have a lot of problems with memory issues and game crashes with message “Not enough memory”. Disk C is almost full. When I exit game - space is returned to normal state.

1 Like

The annoying thing is that they aren’t willing to acknowledge the issue. The content is fine but one can’t enjoy it because it keeps crashing. And it clearly isn’t worth paying for when the product is faulty to the point of almost unusable.

Ive had this problem today aswell, i managed to take a screen-print when the game crashed, the game was then using 18gb out of my 32gb of ram which normally only uses 4-6gb at most in fully populated areas.

The crash happened in the Dream zone, one inside the WorldKillQuest while pvp was active, one in some random place with warmode off.

After some research from older threads with the same error they report it as Addons being corrupted and in need of update or an Ui reset is needed.

Same issue here. Switching to “DirectX 11 Legacy” in Graphics API fixed the issue for me. By the way Blizzard, I reported the issue on the PTR. Do you guys do not read bug reports ?

hoho i thought i was alone with this, major buffering issues and loss of memory since last patch i think. crashes once and awhile. wich i never have done before.

1 Like

Don’t worry, brother worgen, you really are not alone, there are many of us, but that doesn’t make it any easier, unfortunately. And the prospects are not yet clear.

Changing to Dx 11 Legacy helps with disk space. But then it’s 30-40 FPS max (RTX4070Ti here). Still not a solution.

1 Like

I’ve had same issues - the gaming running out of memory. So despite having 32 gigs of ram - I increased the virtual memory from 5 gb to 25 gb - that seems to have ‘halted’ some of the leaks.
If not - I guess wow needs 64 gigs now. lol Blizz Pls!

dx11 made it crash much faster for me.

what annoying is the lack of response from this big company.

"We have identified and are working to fix an unlimited memory growth issue affecting DX11 Windows users and all Mac users. Ideally, we should release a build with the fix early next week.

In the meantime, typing /console gxrestart in chat will return the client to normal memory usage (but it will still continue to increase after that). On Windows, using DX12 or DX11 Legacy backends should completely eliminate the error.

For those interested in the code side of things, the error was that the call to std::deque::clear() was incorrectly placed in a block of code that only compiles for internal clients. This led to the fact that the bug never showed up in our internal testing, but led to unlimited memory growth in public clients."
Here is the answer.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.