Herioc Warfront bugged


#21

I just got the achievement with deathmantle. We killed the heroic warfront. look the reddit. I cant post gyazo links on battle net :confused:


#22

Bro i cleared it at 13:30


#23

its not fixed, was told it was fixed in the raid group i joined. a guy even pasted the text from a blizzard gm that he received. I got the achievement after killing the boss but didn’t get the quest complete…really hope you give the quest complete to the people that has completed this. Having people do it again and still not getting it complete is just annoying.


#24

gm wrote me its fixed. then i did another looking forward to the reward and all i got was the stinky finger in my face for not completing the quest.

gms who are lying into the face of the customer. maybe try it out yourself before saying its fixed!


(Aerandul) #25

Went via Live Chat after the stock response. GM’s are now able to manually flag the quest for completion by logging into your character - just got some 430 boots!


#26

how do i get to the live chat? seems like a secret when i try to find it :stuck_out_tongue:


(Aerandul) #27

Contact Support - Blizzard Support


#29

Seems the fix hasn’t actually fixed the issue. I just completed an hc warfront and never got quest completion, friends in my group did get quest completion for the normal warfront quest however.

Edit - Contacted Support and they sorted me out :slight_smile:


#30

They just told me the live chat isn’t for in game issue.

And make a ticket and wait for a response.


#31

Well hello there,

I was just told in live chat that they will be gifting the quest reward to all players with the heroic warfront completion achievement soon.


#32

Half an hour ago~ Thanks for the quick response Blizz!

Apologies for the delay in getting that all sorted, our developers are currently working on fixing the bug that’s messing with the credit for it, so hopefully that’ll be taken care of soon.

For now, though, I briefly took control of your character, and was able to hand in the quest for you. All rewards have been added to your character, and you’ll find the item sitting in your Inventory next time you login.

Hope that takes care of everything, and I wish you the very best of luck on your adventures!

Prynovarr / Steve M.
Game Master


#33

you spewing out garbage - just completed this for the 3rd time today and still the NPC evade or get bugged out and the quest again did not autocomplete. This is trash like the dumb “rare” that is bugged to #$$%$# thats meant to give mining recipes.


#34

Wow, I’m really impressed, I just received an extremely positive written reply to my ticket: Quest was set to completed by customer support, I received my item and they even apologised for the first answer to my ticket. That’s how support should handle such issues.
So for all others who where not able to complete the quest: Open a ticket (if you have not done so already), they are now acknowledging this bug and give you the rewards for the quest.


#35

Still not fixed. Have done the heroic warfront twice now without the reward. Once yesterday, once today. Quite frustrating as I could really use the gear from the quest rewards. Have contacted Blizz so hopefully by the time I log in tomorrow, this problem will have been sorted for others and I will have my Quest completed. Shame this couldn’t have been sorted earlier though, its been 2 days since reset and still no fix.


#36

i am playing on runetotem-eu it was still bugged for me the herioc warfront quest on the victory screen it did not complete my quest so i can not turn it in plz blizzard fix this ! :smiley:


#37

I opened a ticket 1 day and 12 hr ago…still not had a response yet :stuck_out_tongue:


#38

Hello, I did also do HC warfront and it didn’t complete my quest, I have the achievement, did warfront 2 more times (altogether 3 wins) yet It still didn’t complete the quest for me, is there any way I can solve this? I am asking because I don’t want to spent more time with pointless stuff, seeing as I already spent around 1 and a half hour doing it 3 times… thank you for understanding


#39

Just make a ticket. That’s all you can do now.


#40

the quest works now for me


(system) closed #41

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.