"I Pitied The Fool" achievement in Arathi Basin

Neither me or my SO are not getting any credit from doing /pity on a love fool in Arathi Basin. It doesn’t work if I put it down, another member in my group puts down one or one from the enemy factions. I read on the US forums that a lot of people there are having trouble with this too. It’s the only one I have left and I would really like it finished. I have opened a ticket and we’ll see how it goes.

Anyone else ran into this bug?

9 Likes

Yeah, I did as well, wasted 2 of my Love Fools trying to do this

Same here, I used it twice, once on the start and second time in the end of BG. 20 tokens of love wasted :slight_smile:

Checked wowhead and apparently blizzard knows about it and are working on it. Hopefully it will be fixed soon.

Just tied to do Arathi Basin Blacksmith portion for the I Pitied the Fool achievement and didn’t get any credit for it. Tried it once inside the blacksmith and once outside. Anyone else experiencin this. Looking back in forums and Wowhead it looks like this achievement has been bugged almost every year.

2 Likes

Same for me, we tried with couple of people on the Arathi Basin’s blacksmith, no one got the achievement. I want my love tokens back:(

Having the same issue

Ever since the arathi basin rework, we need to cycle through each individual seasonal arathi basin achievement for them to get fixed.

Let’s just hope this one gets done before the event is over.

I’ve tried it twice and failed once =(

I wonder though, why every event must have something broken in it?

People have been reporting this through the Bug Report in Help as well, and we have received some tickets about “I Pitied the Fool” not working in Arathi Basin. All of this has been passed on to the developers for now, I don’t have any ETA for a possible fix, however I do know in the past a similar bug also existed (for those old timers among us!), so hopefully it can also be fixed soon before the Love is in the Air event ends. I would keep an eye on the Hotfix page for now: https://worldofwarcraft.com/en-us/news/23277654

Same thing here

Its 3rd day with no fix it . HOW get this for [Fool For Love] its the last what i miss it. If support not fix to the end event then what ?

1 Like

I am having the same problem. I’ve wasted two of my Love Fools trying to get it done.

i got the same at wintergrasp i think i tried it 5 times so far

Ticket from Blizz :slight_smile:

Tirwechi
Greetings,

Kate here, aka GM Tirwechi, at your service!

We’re awfully sorry about the wait time for this response. We’re currently very busy, but are doing our best to get through the queues as quickly as possible :slight_smile:

I checked into this, and it seems that the bug from 2017 may have reared it’s ugly head once again, and be causing problems.

To get this resolved, please can I get you to submit a bug report in game (I have already raised it as a concern, but player reports are more valuable since they include game files), our QA team can work on sorting out a solution :slight_smile:

I’d recommend trying again later this week, and hopefully things will have been sorted :slight_smile:

I’ll leave you with a GM joke for now, to help make the day slightly better :smiley:

What do you call Thunderbluff on fire?

The start of an AWESOME bbq, of course! (Bet you can’t guess what faction I play!)

Thank you for contacting Blizzard Customer Support, and I hope you continue to have a great day and a fantastic week/end!

Best Regards,

Tirwechi
English Game Master Team
Blizzard Europe

1 Like

This is still broken, tried yesterday and today with no luck. That’s 4 Love Fools wasted. :confused: Hopefully this gets fixed before the events ends, as this is the only bit I have left of the Fool for Love Achievement.

We have the same problem on the German servers aswell. I wrote a ticket and got an answer two days later. The GM told me that they’re probably going to fix it on Wednesday, 12th February during the server restarts. Let’s hope for the best.

Wintergrasp worked for me. I did it in the old zone in Northrend, not in the new bg.

Just tried it and it worked for me!!! Maybe it was fixed in the hotfix just released! Thank you blizzard, no need to wait for another year :stuck_out_tongue: