Missing Ash'adar mount! Wheres my glowing kitty?

Blizz can you fix this all ready, I finished my journal over 7 hours ago completed it and when I went to Stromwind the only thing that fell out the chest was 300 coins and no mount. When you open my journal on all my alts as well the bar fills all the way up and ding but even after logging in and out and reloading still nothing. Grinding til 6 am because I thought yeah I’ll go to bed having completed this :-(. Saw another person in Stormwind with same issue.


300? I got 700 and no mount? I have the same issue. Can’t find it anywhere


I wish they fixed it, it was down extra long Thursday for maintenance and now kind of stinks seeing others mounting up and we’ve done it to but still haven’t receive our reward . Opened a ticket and they answerd it just checking it solved, but there was no solution and now theres a 4 day 17 hour wait. So I think many have the issue to :frowning:

Same for me. Finished the 1K grind, opened the chest but only got Trader’s Tender

1 Like

The mount should be a gift in mount tab not in the box

1 Like

Same problem here. After finishing the 1k bar and opening the chest, I only got 200 tender and no mount, not in mail nor in mount collection tab as a gift or otherwise.

1 Like

Exactly checked everything to. Little crappy a whole day after and no fix.

I’ve had the same problem, I opened a ticket and then it was just marked as resolved without a fix. Not exactly helpful.

I understand its a new system and bugs can happen, but this isn’t funny.


ty lol i hated that to , what was resolved >> were all still waiting :frowning:

Same here. I thought i was doing something wrong.

My traveler’s log says "You have collected all rewards for this month" but there’s no mount. Restarted the game, the bar reset to 0 :joy: Clicked the Trading Post NPC (Shiri) and rechecked the traveler’s log and luckily it’s back to "You have collected all rewards for this month" but still no mount. Not in the mount journal, not anywhere :face_with_raised_eyebrow:

Imagine going on a tantrum on the forums over a mount. Touch some grass my guy

We all got the same problem.
I can’t believe how blizz release this thing full of bugs.

1 Like

yep got the same issue.

1 Like

Not really a full tantrum and grass is great I might add. Don’t belittle what someone else might have a thought about. You yourself have quibbled over things in your life another might find questionable. Were merely hoping they fix the issue since we’ve already invested our time and monthly subscription fee. There are many more important things that happen in the world, Those are being addressed with efforts from many, myself included, but we ourselves would loose our ever loving minds if we didn’t have small vices to quell the real Senseless violence’s that happen in the world. We merely join in our hope on the forum, over something small and doable that can be fixed and hopefully will be soon. I bid you good day.

1 Like

Customer Service cannot help you with this.

Blizzard has ordered a new shipment of riding glowkitties. Unfortunately, they have been delayed.

1 Like

Obtained the mount after doing the first set of monthly acheivements. Flown it for 2 weeks but today unavailable. Just a yellow square in my inventory next to the mount name.

same but green square for me and the transmog’s, I bought don’t show up at all. This best not be a you can only use them for that month BS otherwise it’s a waste of time farming the tender.

You can still use it.
It is invisible right now, so you are basically running through the air at mount speed.
It’s awesome

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.