[mod:rctrl] and other right side mod conditions broken

I had some macros with conditions like:

/use [mod:rctrl]Ability1;[mod:ctrl]Ability2;Ability3

(I remapped left Windows key to right Ctrl to get more usable modifiers on the left side).

Today I noticed that those macros no longer work as intended — in the above example Ability1 executed when I pressed either left or right Ctrl, and Ability2 could not be invoked at all. I tested the behavior of other similar conditions such as [mod:rshift] and [mod:ralt], and found that apparently these conditions now also behave exactly like [mod:shift] and [mod:alt], ignoring the r part.

Is this an intended change, or just another bug which hopefully would be fixed?

1 Like

BRO! I was going crazy. i also made a thread about this:

I really hope they fix this as I simply cannot play with this issue present.

1 Like

Still broken as of 25/10

1 Like

Still broken as of 04/11 on retail and now also broken on Shadowlands Beta where it worked before the latest build…

Less than 2 weeks left before Shadowlands releases and this issue still remains unsolved.

We are now 2 days away from Shadowlands release and this serious issue still remains unfixed. Can we please get a reply at least from Blizzard if/when this will be fixed?

Simple example macro to reproduce the issue:

/cast [mod:lctrl] Hearthstone; [mod:rctrl] Dalaran Hearthstone

Clicking this macro with right control modifier should cast Dalaran Hearthstone but casts regular Hearthstone instead

Even on the US forums, people have been posting about this for more than a month but there is absolute silence from Blizzard:

Hey Elven. I reported this issue on EU forums since prepatch and nothing has been done since. i saw your post on US forums and I am finding that no multikey modifiers work. Could you please confirm? On your post which you last edited on 11 Sept you said that some still worked. I have checked ctrlshift for example and sadly it does not work

I haven’t been having issues with it (I mostly use shiftalt) and I wasn’t having issues with ctrl+something else when they were bugged. That said I’ll check.

Tested with the following and it’s working as intended

/cast [mod:ctrlshift] Shadow Word: Pain; [mod:ctrl] Vampiric Touch; [mod:shift] Mind Flay

shiftctrl is working also.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.