Rshift, rctrl, ralt modifiers not working. Behave like normal shift/ctrl/alt

Anyone else experiencing the same?

Hi hellfiend,

I just checked this ingame and was not able to verify any issues using the modifier (or mod) commands in macros. It may be worth posting this on the UI and macros forums to get some further help there :slight_smile:

Thanks!

1 Like

Hi Frumlac,

Thank you for the reply. i just checked the UI & macros section and it sadly confirmed my suspicions that the prepatch indeed broke the functionaly of the RIGHT side ctrl, shift, alt modifiers:

This is a serious issue as now we cannot make use of the right side modifiers. I have many macros with rshift & lshift for example that do very different actions depending on which shift is pressed.

Also This on US forums: It is conformed to be broken:

1 Like

I briefly experimented using modifiers shift/lshift/rshift & ctrl/rctrl/lctrl without any issues - however I did not try using @mouseover (or similar)

Can you report a bug (if you’ve not already done so) for this please?

It is when you use both modifiers in the same macro that the issue is exposed. Before the prepatch and now on the Shadowlands beta, it works flawlessly.

rshift is not being treated as rshift. It is being treated as lshift i.e shift and that is not the way it has always worked and this is an issue that needs to be addressed.

Try this: use rshift to do an ability on focus and lshift to do the ability on a different target in the same macro. You will see that rshift will refuse to do anything as it is being treated as lshift.

For example this is a macro I have used for years and all my macros across all my classes are similar:

#showtooltip
/cancelaura Bladestorm
/cast [mod:lshift, @arena1][mod:ctrl, @arena2][mod:alt, @arena3][mod:rshift, @focus][] Storm Bolt

Now they all refuse to work on focus as rshift is not being recognised as a separate modifier.

After some further digging, I found there definitely were some investigations into macro behaviour within the past days - is this still ongoing after the hotfixes applied today?

It is being tracked though - fingers crossed!

2 Likes

I am playing right now and yes sadly it is still broken. I am glad to hear that it is being looked into as this is a very important functionality that I among many others have used extensively and would find it a hassle to play without. The fact that it works on the Shadowlands beta but not on retail and PTR should make it very easy to fix I think.

Still broken as of today (9.0.1 build 36372)

Simple example macro to reproduce:

/cast [mod:lctrl] Hearthstone; [mod:rctrl] Dalaran Hearthstone

Clicking this macro with right control modifier should cast Dalaran Hearthstone but casts regular Hearthstone instead

2 Likes

This is so frustrating. I really hope there is a fix before Shadowlands. having to go through prepatch with this is a pain as it affects every single macro I made across all classes.

This was working fine on Shadowlands Beta but now sadly it is broken there as well. Looks like the latest update Blizzard pushed to the Beta broke rshift, rctrl and ralt.

Hello Ferumlac, just checking whether this is really being looked into. It has been more than 2 weeks and this issue not only persists but has now unfortutanely been applied to the Shadowlands Beta as well where it previously did not exist.

As Wodzoomer said,

Simple example macro to reproduce the issue:

/cast [mod:lctrl] Hearthstone; [mod:rctrl] Dalaran Hearthstone

Clicking this macro with right control modifier should cast Dalaran Hearthstone but casts regular Hearthstone instead

We are now less than 2 weeks away from Shadowlands release and this issue is still not fixed

1 Like

Dear Ferumlac,

It is now a whole month since you last posted here and 2 days before Shadowlands releases and this issue still remains. This is very concerning. Can you give an update whether this will be fixed? It is a major issue if rshift, rctrl, ralt cease working as intended and instead behave like their left counterparts as many people including myself rely on those modifiers for various macros.

1 Like

7 days into Shadowlands and this is still broken. Come on Blizzard is it too much asking for an update on this issue?

1 Like

Are you going to quietly brush this one under the carpet Blizz? I among many people submitted bug reports in game about this since prepatch and nothing has been done. Does this mean this will never be fixed then?

1 Like

So. When will this be fixed?

1 Like

Sadly it looks like Blizz is going to brush this under the carpet. We have had 0 acknowledgement from them. Such a shame and pretty gamebreaking. I just tested and it seems multikey modifiers such as Shiftalt etc are also broken now. Very sad if they go unfixed.

1 Like

Multi-key modifiers are working. It’s just left/right modifiers that are still busted.

This is still broken. What is going on at Blizz HQ?

Indeed. unbelievable to say the least. I just had to accept that this will most likely never be fixed.