Wow causes whole system to freeze reboot required NO SOLUTION YET! happens on multiple full AMD systems NO SOLUTION FOR 206 DAYS

This happens exclusively in wow i play anything else its fine, it happens on both older gpu drivers and newer, AMD gpu drivers have huge issues currently with MPO so MPO is disabled but even on older driver with MPO enabled i get system freezes, i am lucky if i get a tdr instead.
I think this has been going on for couple of months but now especially gotten worse.

There been times if had no system freezes for 15 hours and there been times if had system freezes every 2 hours consistently if no idea whats triggering this, im about to give up and just ask for a full refund on expansion and 12 months subscription because whats the point if i cannot play i may as well just give up.

Operating system: Windows 11 22H2 22621.819
Case: Lian Li PC-O11D XL ROG Certified White
Mainboard : Asus x570-E (4021 agesa
CPU: Ryzen 9 5950X VMR-B2 stepping PBO watercooled💧
Ram: 4x8 GB G.Skill Trident Z Neo F4-3600C16Q-32GTZN Samsung B die 16-16-16-36
GPU: Liquid devil 7900 XTX
NVME: 2x samsung 980 pro 2 TB :fire:
Storage: 2x Samsung 860 EVO / 2x Crucial MX500 2TB SSD / 1x WD40EZRZ 4TB
PSU: be quiet! Dark Power Pro 12 1200W :electric_plug:
Display: LG 38WN95C-W 3840x1600 144hz :desktop_computer:11,9 inch system info display​:desktop_computer:
Cooling: 2x EK-CoolStream PE 360 Radiator + 1x EK-CoolStream SE 360 Slim Triple + 10x EK-Vardar EVO 120ER D-RGB (500-2200 rpm)
Keyboard: Keychron Q1 QMK carbon black brown switches 1000hz
Mouse: Logitech G903
Sound: Hyperx cloud flight S
Webcam: Logitech Brio 4K Business Edition


I am suspecting the game has a huge memory leak, happens with and without addons.

GPU upgraded to a liquid devil 7900 XTX still same issue exclusively with world of warcraft.


proces analyzation is saying its in a deadlock state

wow.exe is in a deadlock. You can either end the process to clear the deadlock immediately or wait to see if the problem resolves itself


I am not 100% sure, but the use of the term "PID: " make me think you are using a Linux distribution of some form. Not Windows.

If this is so, you should be aware that Blizzard do not support Linux. That is to say, if you run into problems, you’re on your own, you will get no official help from Blizzard.

No i am on windows 11 what makes you think its linux by looking at pid ?
Any idea whats causing this dead lock if i analyze another app like heaven benchmark it does not show it, it only shows on wow even on diablo 3

From what i read it can be number of things causing it like gpu giving errors ssd or memory but i am already testing with new mem kit, if ran without freezes playing elden ring running sackboy or even running heaven benchmark over night
but wow just randomly freezes every 1 to 4 hours now

That would explain why I have never seen windows use the term PID, I have only seen it on Linux systems before. I only have Windows 10, and Windows 11 does not offer enough to make me want to switch. In fact it takes away some stuff I use regularly.

Microsoft is in love with linux you can install linux kernel as well i guess it adopted a few standards, i love using linux shell on my raspery pi and synology :smiley: setup various things.

Anyway i do not understand why wow proces is in deadlock state its appearntly not getting acces to resources, i know if seen graphical errors that my friends also reported on their hardware, difference being i have 6900 XT and he has a gtx 1070 a hulking warflesh from bastion had no spine i swear Blizzard just broke wow and people have stuttering or freezes in my case its causing permanent system freezes.

Even with older gpu drivers.

I think its freezing because of compute effects now and game running out of sync if any kind of synchronisation is enforced like vsync / enchanced sync appearntly disabling fullscreen optimisations makes frametime more stable if had test where i played for 15 hours without system freezes and then decided to re enable it again and problems got worse.

I have to test more to confirm.

But what happens is compute on ultra it takes a while so gpu downclocks then spikes up suddenly and when it does this a lot it eventually leads to gpu freezing, 6900 XT is not a very eficient card it can peek draw 1000w and i am on a 1200 watt titanium rated power supply be quiet! dark rock power pro 12 1200w it does not matter if i am on single rail or multirail either.

Tested cheap ram kit did not matter either did clean install.
Yet to encounter system freeze but i am on windows 11 21h2 now cos i do not trust 22h2 at all anymore, paused windows 11 updates as well via connection via data limit trick

Only having installed the essential stuff.

Also disabled MPO tryit testing with MPO but AMD gpu drivers just blackscreen still Microsoft must have messed something up badly cos with MPO disabled if never been more stable.

I can play other games just fine no problem.

I may turn off compute effects completly right now if set it at good instead of ultra.
Haven’t disabled fullscreen optimisations yet but i am defiantly gonna do that.

I think the system freezes because the gpu crashes on compute and the proces is in a deadlock state not giving resources back or something.

Really encourage Blizzard to fix this is not a issue exclusive to my system grabbed my 10 year old laptop also reports the same dead lock when proces is analyzed Blizzard may claim its not an issue but it clearly is, if my gpu crashes it should get a tdr and recover not freeze up the entire system because of a game proces that does not handle resources well.

Other games do not show deadlock state either when analyzed.

I do not experience stutter but i did experience minor stuttering early in pre patch but it went away after compiling shaders

edit: running 7 hours and 18 minutes without system freezes gpu core clock speed has’t spiked yet to 2550mhz it does this on stock as well usually when it loads assets into gpu memory it will spike to those speeds as well i found out altho im not exactly sure what conditions exactly yet it does this.

Anyway if had tdr on older drivers no system freezes yet, i think compute effects are broken and overload gpu

edit: compute effects may not be related.

1 Like

I’m tryng this and make all my guild tryng this, guess what?
It actually increase fps and reduce stuttering for EVERYONE!!!
all gpu from amd and nvidia too got all a bump in fps and fix stuttering issue! ALL
So, what the heck is going on Bliz???

Im having a lot of system freezes i read some one else fixed some issues disabling that and lowering compute effects and appearntly it had positive impact on frametiming also seems screen recording had positive effect, my AMD gpu has blackscreens and i discovered month ago or so that screenrecording made things stable as well preventing blackscreens with MPO on but it was not a reliable fix so i disabled MPO instead.

What screenrecording does on AMD tho is if you have vsync on in game and enchanced sync on in amd control panel and you screenrecording enchanced sync will disengage somehow ingamevsync gets priority and i think vsync enchanced sync depending if setup correctly will fix timing issues, btw you want to disable vsync in game if you set vsync or enchanced sync at driver control panel atleast for AMD.

Anyway i got a log and there been times i had no system freezes and 15 hour game session i forgot i had fullscreen optimisisations off at the time, but i never touched compute quality and this was also with vsync globally forced off and turned off in game and MPO disabled, forcing vsync off with MPO enabled is gonna give you bad time tho highly not recommended on AMD gpu’s drivers are a mess right now because MPO is broken.

btw mpo was broken for nvidia 2 years ago or so as well.

edit: MPO is known to cause stuttering but also blackscreens with AMD users

This doesn’t fix the issue at all, I do this by default for all games. I’ve tried everything and the pop-ins and stutter persists.

Might be because you have MPO enabled altho i would not disable MPO unless it causes issues, MPO can cause stuttering as well
Nvidia has a page up for when it had issues with MPO disabling MPO was a temp fix back then
I would be quite surprised if this fixed stuttering or even other issues for Nvidia users right now, it would mean MPO is broken even more and not that AMD drivers being broken.

I think disabling MPO causes issues with compute effects maybe as well altho if had driver tdr’s with compute effects on ultra on older drivers with MPO enabled and system freezes and tdr’s on newer drivers with MPO disabled, i just had a 10 hour and 30 minute wow session seems setting compute effects to low or good has huge impact in avoiding tdr’s and system freezes potentially, i have to test this for least a week to know for sure tho, just like i did with disabling MPO.

Im not a fan of placebo’s

If been running for almost 24 hours now without gpu crashes / system freezes it seems compute effects are broken atleast on AMD gpu’s atleast on my 6900 XT perhaps because MPO is disabled, but MPO is broken for AMD so i cannot turn this on.

What happens is GPU gets high compute load drops 3D clocks by a lot then spikes up and crashes.

Looks like compute effects are crashing AMD gpu’s or atleast mine possibly because MPO is disabled but if had it happen on older drivers with MPO as well, devs better look at compute effects cos it always caused huge freezing spikes but appearntly they got so big it freezes the system permanently now.

If had wow running for roughly few more then a day without freezes sessions around 8 to 10 hours each time.

Setting compute effects good or disabling fullscreen optimisations seems to be doing the trick, if done both now i noticed rain and weather effects add about 15% sometimes 25% peek load on compute engine im guessing it go’s way over 100% when it freezes system permanently it probably causes gpu driver to crash with game being in deadlock state it causes a system freeze instead at times.

nvm just had system freeze in 2 hours and 13 minutes it starting to look like either my eset internet security is causing issues chipset drivers are broken with balanced power plan or something else installed or my cpu is failing and doa and only staying alive due to good cooling and tripping.

I still have no idea why it only happens in wow
Did the game start using direct storage cos anti virus can be incompatible with this however my anti virus does not report any issues with direct storage i think

This at least should be fairly easy to test. Anti-virus software can cause the weirdest issues.

Try to uninstall it fully and just using Windows’ own integrated AV and see if the problem persists.

We might have the same problem.

Does your system freeze like mouse freezing and you have to power off the computer?
I took a video of it now.

Win11 22H2
AMD Ryzen 5 3600X
Radeon RX 5700
Kingston KHX3200C18D4/ 32G RAM
Corsair TX650M, 650W PSU


Yes like that.

Atleast you are not alone then!
Cant say i have anything to fix it thou :frowning:

Any of you run nvme with game installed on nvme ? or have wallpaper engine ?

I run it on a nvme drive yes, always has.
I have the same computer i played shadowlands at the start when there was no problems.
Had a year long break and came back for DF so no idea when it started. Plays all other games fine.

I also created a new thread for my issue

If you do not mind sharing specs so i can figure out if there any similarities in hardware spec like having AMD gpu or AMD platform like cpu etc
Im starting to suspect what the issue could be but i am not 100% sure yet