Problema al agregar suscripcion

Hola, siendo de Argentina empecé a jugar en servidor español, al principio pude comprar el juego completo y una suscripcion de 1 mes sin problema alguno (previo a varias limpiezas de caché y cookies) pero el tema es que habia alojado la cuenta como española. Arreglé la situación y la encuadre como cuenta argentina, ahora cuando intento ampliar mi suscripcion a la de 6 meses, no me toma el pedido. Trato de explicarme, cargo los datos (probé con 2 tarjetas visa) y llego hasta la parte que me pide la contraseña para confirmar el pago. Después de ahí, me deja con un “espera un momento mientras nos encargamos de unos asuntillos” y la parte de volver a cargar mis datos, asi desde hace 3 dias. Ya en mi cuenta de américa tuve un problema similar, de hecho aqui compraba tiempo de juego en vez de suscripción, pero no se si pueda hacerlo con una cuenta de Europa. Ya he vuelto a limpiar cookies y caché y eliminado y vuelto a cargar los medios de pago. Cualquier ayuda se agradece

Puedes intentar seguir los pasos de resolución de este articulo:

Ten en cuenta también que una entidad bancaria puede bloquear por seguridad las transferencias y pagos internacionales.

Igualmente al tratarse de un tema de pagos el equipo de Blizzard que trabaja en los foros no puede tratar este asunto de forma personalizada.
Para verlo con mas detalle lo mejor es abrir consulta para revisar que esta ocurriendo:

1 «Me gusta»

Hola, al final lo pude lograr, me sugirieron via ticket un par de cosas y funcionar. te agradezco por el link de contacto con asistencia al cliente, por que me vino bastante bien. Podes cerrar este tema, gracias!!