WoW Classic et Linux


#1

Hello,

J’aimerais savoir si WoW Classic pouvait tourner avec Linux. Et si oui, quelle version ?

Merci !


#2

Salut,
Je suis sous Ubuntu 18.04
J’ai installé battle net via Lutris et j’ai aucun soucis pour jouer. Pas de Lag rien.
Par contre, j’ai pas encore mis d’add on donc je peux pas te dire si ça marche et comment faire.


#3

Comme dit précédemment, le jeu tourne sans aucun problème avec Lutris.
Les « add-ons » s’ajoutent manuellement dans le dossier Interface.


#4

World of Warcraft tourne très bien sous Linux via wine-staging (pas besoin de lutris et compagnie).

Si ta machine est faiblarde, dxvk fera du bien aux images par secondes.


#5

Personnellement, j’ai opté pour une petite partition Windows 10 rien que pour WoW parce qu’avec wine c’était pas ça niveau framerate. Mais je ne connaissais pas Lutris. :thinking:


#6

Merci à tous de vos réponses !


#7

Hello

Jusqu’à hier , WOW Classic fonctionnait très bien sous Lutris, j’ai fait une mise à jour de Lutris, battlenet et wow s’ouvre normalement , mais lorsque je choisis le serveur ou sont mes persos, ça met “connexion au serveur de jeu” et rien ne se passe.
Quelqu’un a t’il le même problème que moi ?
Merci d’avance.


#8

Le problème a été signalé ailleurs déjà.
Voir Bloquer sur "Connexion au serveur de jeu" + WOW51900328 avec peut-être une solution en fin de thread


#9

Alors j’ai eu le soucis ce matin et j’ai réussi en passant sur IPv6.
Après,faut aussi cocher la case dans les options du jeu.
Si ça marche toujours pas, ya un post dans assistance qavec une manip à faire dans le terminal.
Moi ça a fonctionné


#10

Merci à vous.

J’ai réussis à régler le problème grâce à une solution proposé sur le forum de Lutris qui consiste à modifier le fichier ip_default_ttl se trouvant dans /proc/sys/net/ipv4 en remplaçant 64 par 128.

Bonne journée.


#11

Çà marche pour moi avec Lutris sous Debian Sid. J’ai utilisé le lien pour Wow retail environ vers fin juillet.