Flackern auf den Bildschirm

Bei mir flackert es seit 8.2 und zusätzlich noch erhebliche Probleme mit fps. Vor 8.2 lief noch alles super. Das flackern kann denke ich nicht an der Hardware liegen, weil ausserhalb von wow läuft alles super. Ich habe übrigens auch komplette neu Installation ohne Backup gemacht, auch wow neu installiert, das flackern war weiterhin da.
MacBook Pro 15 Zoll Retina (Mitte 2015)

1 Like

Das liegt eindeutig am Patch, habe es auch und nur bei WOW !!

2 Likes

Ich hab das Problem auch … Ich hab testweise auf DX11 umgestellt und dann ist das Problem weg. Schalte ich wieder auf DX12 dann seh ich sporadisch z.B. auf der Map ein Flackern von schwarzen Quadraten oder Icons flackern. DX12 läuft bei mir sonst schon seit Monaten ohne Probleme und jetzt plötzlich diese Artefakte.

2 Likes

Der Fehler ist Blizzard durchaus bekannt !

Hier Mal aus dem englischen Forum

Betroffen sind Nvidia Karten im Dx12 Modus und neuen Treibern ab 430.87.

Auch der neue Hotfix Treiber hat bei mir keine Besserung gebracht.

Es treten schwarze flackernde Kästen auf der Map auf, ui flackern und teilweise auch merkwürdige Grafikglitches.

Ob das Problem nur im Zusammenhang mit dem Win10 Update 1903 und Nvidia Treibern besteht weiß ich nicht.

Abhilfe schafft nur eine alte Treiber Version oder auf Dx11 zu wechseln.

Anscheinend steht Blizzard auch schon mit Nvidia in Kontakt um das Problem zu beheben.

Mein System:

Win10 Pro 1903
Ryzen 5 2600
Gtx 1060 3GB
Msi X470 Pro

Win würde sauber neu installiert, Chipsatztreiber aktuell, neuste nvidia Treiber und an software nur wow installiert und der Twitch Client.

2 Likes

Ich habe das Problem, sobald ich in einer bestimmten Höhe im Spiel bin, dann fängt bei mir alles an zu flackern. Wenn ich am Boden bin, läuft alles ohne Probleme. Aber ist ja schon gelöst worden. Danke Himbeer, für deine offenkundige Meinung.

Habe soeben auch das Flackern mit DX 12 festgestellt. Es flackert sporadisch das UI in Teilen, d.h. z.B. die Minimap, Charakterbild, die rechte Iconleiste, etc. Farbige Flächen, Fraktale habe ich noch nicht festgestellt.

System: Win10 Home 1903
I7 7700K
Gtx 1070 8GB
Prime Z270-K

Nvidia Treiber: 430.86

Edit: Hab mal den Hotfixtreiber 431.18 ausprobiert. Bislang kein Flackern mehr.
Edit 22.07.19: Flackert auch mit 431.18.

Das Problem hatte ich auch und ich hab die Lösung gefunden und zwar hab ich DirectX 11 aktiviert. Kein Flackern mehr nix. Ist zwar schade, aber ich warte mal ab, ob Blizzard was macht. Denn wenn es soviel Spieler haben, kann es nicht an uns liegen

Gut interessant, es lag doch an mir. Das Native war schuld, ihr müsst das echt deaktivieren. Es läuft sehr flüssig nun und ich habe kein Flackern mehr gar nichts.

Dachte schon es liegt an meiner RTX 2080 Ti xD dabei haben auch andere das Problem, gut das es erstmal hilft von DX12 auf DX11 zu wechseln. Fand schon komisch das ich dieses Problem nur bei WoW habe.

Treiber habe ich übrigends 430.97 am laufen.

1 Like

Also ich hab manchmal so ein schwarzes Flimmern bild wird für eine Milli aber wirklich so eine kleine Milli sekunde schwarz? liegt es an Dx12? und zB wenn ich die Map öffne dann hab ich irgentwo auf der Map ein kleines Viereck was anfängt zu flackern und manchmal bewegt es sich auf eine andere stelle

Hier mal mein system

i9 9900k
RTX 2070 OC von Asus
MSI Z390 MPG PRO CARBON
32GB DDR4 3000mhz

Vielleicht hilft euch meine Erfahrung weiter. Ich hatte auch keine ganze Zeit das Flackern, seit 8.2. Dann habe ich allerdings das “Spielinterne Overlay” von NVIDIA deaktiviert und seitdem gibt es kein Flackern mehr bei mir.

Ich denke es hängt mit den Funktionen von diesem Overlay ab, welche auch nebenbei das Spiel permanent aufnehmen kann, um die letzten 5-10 Minuten dann zu Speichern. “Highlight Funktion” oder so.

Einfach mal abschalten in der “GEFORCE Experience”.

Aus dem PDF der neuen nVidia Treiber:

[World of Warcraft Battle for Azeroth]: Terrain and icons flicker randomly in the game. [2633205]

Offenes und bekanntes Problem auch in 431.36 WHQL.

Betrifft das Problem nur die RTX GPUs?

Hab noch ne GTX 970 mit 430.64 und unter DX12 keine Grafikfehler irgendeiner Art.

Kann schon sein das es nur die RTX Karten betrifft. Hab eine woche in etwa 8.2 mit einer GTX gespielt ohne probleme. Seit ein paar Tagen mit neuem Rechner und einer RTX 2070 und das selbe Problem.

Ich hab auch ein Flackerproblem… aber NUR in SW bisher. Dabei flackern Texturen über den Bildschirm wie Gras, Leere, Fels, Holz usw. Kleines Beispiel hier ( https://www.youtube.com/watch?v=-BLzYbBz744). Das Ding ist, dass ich sonst nirgends diesen Fehler habe. In Silithus nichts und in den aktuellen Addon gebieten auch nicht.

Windows 7 64-bit; i4770K ; 16 GB RAM; GTX 1060 6GB VRAM; Installiert auf einer Nagelneuen SSD

edit Wenn ich in Silithus vom Schwert wegfliege passiert nichts aber wenn ich darauf zu fliege flackern die gelben Azerittexturen übers Bild, bis ich auf 40 m ranfliege, dann passiert nichts mehr -_- Scheibenhonig! Meine Graka ist in Ordnung, mein Monitor auch. Verträgt sich der aktuelle Nvidia Treiber nicht mit WoW ?

Hatte ebenfalls dieses Flackern mit DX12.

Mein System: Intel i9 9900k @ 5.0 GHz 1.27 Volt, Asus ROG Maximus XI Code 32GB 3000MHz DDR4 CL16 DIMM Kit (4x 8GB) G.Skill TridentZ RGB, RTX 2080 ROG Strix Gaming OC, Seasonic Prime Titanium 650W

Der Wechsel auf DX11 hat den Fehler behoben, vielen Dank für den Tipp.

Hallo, also bei mir half der Rückschritt auf den Nvidia treiber:30.64!

Mein System:

I5 9600k

Z390 AORUS PRO WIFI

16 GB Fury 3200

RTX 2070 OC Palit

Wollte nur mal einklinken und sagen, dass ich genau das gleiche Problem habe.

Hab mir vor ein Paar Tagen einen komplett neuen PC zusammengebaut, es ist also eine komplett neue RTX 2070 verbaut und ich habe NUR bei WoW das Flackern. Also es flackers Menüleisten und manche Fenster.

Mit meiner alten GTX 980 gabs das Problem nicht.

Nabend Leute,
ich sollte echt mal öfters ins Forum schauen, dann hätte ich mir viel zeit und geld gespart die letzten tage…

Ich habe dies auch bereits im anderen beitrag gepostet, also bitte verzeiht den Doppeltpost, aber dies ist die Lösung!

Ich Depp dachte es liegt an meiner Grafikkarte und habe mir extra eine neue geholt, weil ich exakt den selben fehler hatte…

Hatte und habe eine Asus RTX 2080 ti OC

Und selbst bei der zweiten war der Fehler da und wollte mir schon ein neues Mainboard holen…

Es liegt am aktuellen NVIDIA TREIBER! Ich habe meine Grafikkarten deinstalliert und habe von Windows einen treiber runter laden lassen. Dies war ein 419. … Treiber glaube .69. Dort gabe es keine Fehler. Aber sobald Ich dann wieder den neuesten runter geladen habe kamen die Flackender Texturen zurück.

Seid gestern gibt es eine neue Version und ich dachte mir ich Versuche nochmal mein Glück. Bisher gab es noch keine Fehler, aber habe ihn auch erst 15 min.

Ich hoffe meine Erfahrungen helfen euch weiter! Es liegt definitiv am Treiber! Weder Pc neu installieren, noch irgend welche WoW ordner löschen bringt etwas!

Ich teile mal den Beitrag.

Bis jetzt noch kein Flackern, Flimmern etc. aufgetreten. (BfA-Heros, BGs, Legion-WQ, rumlungern in Boralus)