Diablo 2 resurrected failed to initialize graphics device

I have tried every fix i could find on the internet and nothing works. Every time i click the play button i get a black screen with the message failed to initialize graphics device. I’m on windows 8.1 but i have seen people on windows 10 having the same issue. My GPU is the GTX 1080 TI FTW3 and is more than capable of running this game, and yes the drivers are up to date. I used to play the original D2 on this system but a few months ago that also stopped working for some unknown reason. D2 and D2R are the only games i’m having problems with, all my other games work fine. Anyone got any ideas, i would appreciate the help, thank you.

20 Likes

Same Problem. Nice if someone can help us.

3 Likes

I have tried running it in admin and compatibility mode and also running it from the exe instead of the launcher and nothing works. When i try launching it from the exe my screen goes black like its about to load the game but then it just goes back to the desktop and nothing happens. When i try it from the battlenet launcher it goes black and gives me the failed to initialize graphics device message. I hope someone can find a fix soon.

3 Likes

Same problem. I’m replying in the hopes of getting notified of any fixes that come out.

1 Like

Im having the same issue. Tried running in compatibility mode, admin, updated all drivers, nothing works

Same with me. Hope there will be a fix or a solution soon.

Same here. Tried all the workarounds but nothing fixed it for me. I’m on Windows 10.

Same here GTX 1060 just updated and windows 8.1

Diablo II: Resurrected requires Windows 10 to run… it won’t work with Win 8.1

Unless you can update your Windows, your best bet is to ask for a refund… click the Continue button at the bottom of the following page:

https://eu.battle.net/support/en/help/product/d2r/1930/1932/solution

I have same problem. NVIDIA GeForce GT540M

Hi:

Your video card does not meet the minimum system requirements… see here for details:

Thank you! I will work on it

1 Like

I have the same problem also. I’m running the same GPU and Ryzen 5 2600X with windows 10. And all my drivers are up to date. When I launch the game I get the error.
‘Failed to initialize graphics device. Please ensure your PC meets the minimum system requirements and your drivers are up to date.’

Same issue. Data from blz-log. GTX 970M
9/24 01:34:19.735 [Prism/4] [<>:0]: Unsupported API Backend
9/24 01:34:19.735 [D2Prism/5] [<>:0]: Fatal: failed to create device.
9/24 01:34:19.773 [D2Prism/4] [<>:0]: Available GPU vendor ID 32902 driver version 921768l device name Intel(R) HD Graphics 4600
9/24 01:34:19.773 [D2Prism/4] [<>:0]: Available GPU vendor ID 4318 driver version 859687l device name NVIDIA GeForce GTX 970M
9/24 01:34:19.773 [D2Prism/4] [<>:0]: Available GPU vendor ID 5140 driver version 629164776l device name Microsoft Basic Render Driver
9/24 01:34:21.158 [D2Win/5] [<>:0]: Fatal failure during initialization.

Same issue :C
Drivers update didn`t help.
GTX 970

Exatly same issue I had on windows 8. I installed a windows 10 on new HDD, still have same issue. Geforce GTX 970

Same problem. Have tried many things listed on internet or up here, nothing work.

1 Like

Same here. Trying to make this topic popular to get some attention!

1 Like

i think all we have an onboard graphics card. i disabled it in bios but have the same error. try DDU to uninstall onboard drivers. (i tried but it didn’t work)

Hah! That Boubou just can to say about system requirements ant to advice refund…