Diablo 2 resurrected failed to initialize graphics device

I am absolutely sure my card is compatible and my drivers are current also, very disheartening, i do not know what i can do, halp lol

AMD Radeon R9 290
intel core i5-6600 3.3

ive ran these specs against three or four calculators ive found online, i should be smoking min reqs???

im on windows 10 also, like im well past all sysreqs, it boggles me

Same issue here, I have drivers all updated but it won’t initialize graphics card. Im on Intel HD graphics 4600 NVIDIA GeForce GTX 960M, Intel Core i7-4720 HQ CPU @ 2.606Hz. Tried running as administrator and running w/ high performance, no success yet

1 Like

Same issue here, also sure my card meets the specs.

1 Like

same issue. no resolution. sick!

Same issue here
Cant run it. Looking forward for any support -.-

Same problem here… Already tried everything, all drivers updated, high performace…
Got an MacBook Pro6,3 with windows 7 bootcamp (SSD external) -
Intel I5-8257U 1,4Ghz - Intel Iris Plus Graphics 645 (onboard).

Same PROBLEM! I’ve checked everything. Requirements are covered…updated drivers…???

Any ideas for Blizz support with this bug ?

same issue - looking for fix

I’m running an Nvidia GTX 880M with an I7 and 32 gigs of ram. Am getting failed to initialize graphics device.

estou passando pelo msm problema , minha maquina é uma Fx octa core, 16 ram, placa de video nquadro 6000 6gb, e nao estou entendo o porque nao funciona, por que roda games mais pesados de boa!, ajuda nos ai blizzzard …

1 Like

Same Issue
Processor: Intel(R) Core™ i9-9880H CPU @ 2.30GHz 2.30GHz
Installed RAM: 8.00 GB
System type: 64-bit operating system, x64-based processor
Edition: Windows 11 Enterprise
Version: 21H2
Uploaded on ‎7/‎28/‎2021
OS build 220000.194
Experience: Windows Feature Experience Pack 1000.22000.194.0

Did the same,but still have this issue

i think they gateway like 70% of all players from playing the game… its not on you… its blizzard even when you join the game you get errors and non stop black screens…communication from a 100 billion company is awfull as you can see… no fix for now for any problems

1 Like


windows 7 gtx 1060 gb here

Guys, try deactivate ur default or onboard vga in (device manager > display adaper) first so the game didnt confuse which card they will use, then restart

it works well for me =)


kinda funny that i actually did try to do that…deactivating, caused my computer to glitch up, but i managed to get past the graphics issue…then i had to re-enable and get that graphics error again…i was actually at the realignment part of adjusting my screen…

same problem here… black screen on laucnh, tryied everything on this post

     Operating System: Windows 10 Enterprise 64-bit (10.0, Build 19042) (19041.vb_release.191206-1406)
             Language: Spanish (Regional Setting: Spanish)
  System Manufacturer: Micro-Star International Co., Ltd.
         System Model: MS-7B51
                 BIOS: 1.70 (type: UEFI)
            Processor: Intel(R) Core(TM) i9-9900KF CPU @ 3.60GHz (16 CPUs), ~3.6GHz
               Memory: 32768MB RAM
  Available OS Memory: 32706MB RAM
            Page File: 12841MB used, 24727MB available
          Windows Dir: C:\WINDOWS
      DirectX Version: DirectX 12
  DX Setup Parameters: Not found
     User DPI Setting: 96 DPI (100 percent)
   System DPI Setting: 96 DPI (100 percent)
      DWM DPI Scaling: Disabled
             Miracast: Available, with HDCP

Microsoft Graphics Hybrid: Not Supported
DirectX Database Version: 1.0.8
DxDiag Version: 10.00.19041.0928 64bit Unicode

Display Devices

       Card name: AMD Radeon RX 5700 XT
    Manufacturer: Advanced Micro Devices, Inc.
       Chip type: AMD Radeon Graphics Processor (0x731F)
        DAC type: Internal DAC(400MHz)
     Device Type: Full Device (POST)
      Device Key: Enum\PCI\VEN_1002&DEV_731F&SUBSYS_57011682&REV_C1

Device Problem Code: No Problem
Driver Problem Code: Unknown
Display Memory: 24504 MB
Dedicated Memory: 8151 MB
Shared Memory: 16352 MB
Current Mode: 1920 x 1080 (32 bit) (144Hz)
HDR Support: Supported
Display Topology: Internal
Display Color Space: DXGI_COLOR_SPACE_RGB_FULL_G22_NONE_P709
Color Primaries: Red(0.679688,0.314453), Green(0.275391,0.662109), Blue(0.151367,0.070312), White Point(0.313477,0.329102)
Display Luminance: Min Luminance = 0.086400, Max Luminance = 351.000000, MaxFullFrameLuminance = 351.000000
Monitor Name: Generic PnP Monitor
Monitor Model: C27FG7x
Monitor Id: SAM0E41
Native Mode: 1920 x 1080(p) (143.981Hz)
Output Type: Displayport External
Monitor Capabilities: HDR Supported (BT2020RGB BT2020YCC Eotf2084Supported )
Advanced Color: AdvancedColorSupported
Driver Name: C:\WINDOWS\System32\DriverStore\FileRepository\u0371814.inf_amd64_839416aaebad6c82\B371818\aticfx64.dll,C:\WINDOWS\System32\DriverStore\FileRepository\u0371814.inf_amd64_839416aaebad6c82\B371818\aticfx64.dll,C:\WINDOWS\System32\DriverStore\FileRepository\u0371814.inf_amd64_839416aaebad6c82\B371818\aticfx64.dll,C:\WINDOWS\System32\DriverStore\FileRepository\u0371814.inf_amd64_839416aaebad6c82\B371818\amdxc64.dll
Driver File Version: 30.00.13017.5006 (English)
Driver Version: 30.0.13017.5006
DDI Version: 12
Feature Levels: 12_1,12_0,11_1,11_0,10_1,10_0,9_3,9_2,9_1
Driver Model: WDDM 2.7
Hardware Scheduling: Supported:False Enabled:False
Graphics Preemption: Primitive
Compute Preemption: DMA
Miracast: Not Supported by Graphics driver
Detachable GPU: No
Hybrid Graphics GPU: Not Supported
Power P-states: Not Supported
Virtualization: Paravirtualization
Catalog Attributes: Universal:False Declarative:True
Driver Attributes: Final Retail
Driver Date/Size: 17/09/2021 2:00:00, 1813944 bytes
WHQL Logo’d: Yes
WHQL Date Stamp: Unknown
Device Identifier: {D7B71EE2-305F-11CF-BC66-D8456EC2D335}
Vendor ID: 0x1002
Device ID: 0x731F
SubSys ID: 0x57011682
Revision ID: 0x00C1
Driver Strong Name: oem81.inf:cb0ae41454bd199c:ati2mtag_Navi10:30.0.13017.5006:PCI\VEN_1002&DEV_731F&SUBSYS_57011682&REV_C1
Rank Of Driver: 00CF0000
Video Accel: Unknown
DXVA2 Modes: DXVA2_ModeMPEG2_VLD DXVA2_ModeMPEG2_IDCT DXVA2_ModeH264_VLD_NoFGT {4245F676-2BBC-4166-A0BB-54E7B849C380} {6719B6FB-5CAD-4ACB-B00A-F3BFDEC38727} {9901CCD3-CA12-4B7E-867A-E2223D9255C3} DXVA2_ModeHEVC_VLD_Main {EA72396A-67EC-4781-BEDE-56F498F04EF2} {C152CA8F-738C-461B-AD89-FC292CF8F162} {514A356C-7027-4AFF-8A60-AFD2C1F672F1} DXVA2_ModeH264_VLD_Stereo_Progressive_NoFGT DXVA2_ModeH264_VLD_Stereo_NoFGT DXVA2_ModeVC1_VLD {CA15D19A-2B48-43D6-979E-7A6E9C802FF8} {7C74ADC6-E2BA-4ADE-86DE-30BEABB40CC1} DXVA2_ModeMPEG4pt2_VLD_AdvSimple_NoGMC {D1C20509-AE7B-4E72-AE3B-49F88D58992F} {84AD67F6-4C21-419A-9F0B-24F0578906C1} {725AD240-786C-471E-AD3C-38F739936517} {95664FF5-9E03-4C74-BB4F-9178D6035E58} {5EF7D40D-5B96-49E7-B419-23342094A4CF} DXVA2_ModeHEVC_VLD_Main10 {65D1FA41-58AF-453A-9CAB-5D981156DA9F} {2DB154B6-DBB2-4079-A3FF-60D7A898A6AB} {C74A3FD0-D713-4581-A02E-8EDFB112ACE3} DXVA2_ModeVP9_VLD_Profile0 DXVA2_ModeVP9_VLD_10bit_Profile2 {603A4756-A864-4F91-BB62-2C935B7A1391} {C58B9A06-7E89-11E1-BB00-70B34824019B}
Deinterlace Caps: n/a
D3D9 Overlay: Not Supported
DXVA-HD: Not Supported
DDraw Status: Enabled
D3D Status: Enabled
AGP Status: Enabled
MPO MaxPlanes: 2
MPO Stretch: 16.000X - 0.250X
MPO Media Hints: rotation, resizing, colorspace Conversion
PanelFitter Stretch: 16.000X - 0.250X

Same here need help fix that

I didn’t delete anything