Diablo 2 Resurrected not start

First of all i play D2R preview and beta and work perfectly. Now on final release NOT START… no errors nothing…

Windows 10 64 - updated
Latest NVidia drivers for 660GTX


Same thing for me, doesn’t start… excellent


bei mir auch. Geh auf ,spielen" und dann kommt ,wird aktuell gespielt". Und nix weiter passiert. Hab sogar neu installiert. Kein Unterschied. Aber wieder typisch. Ich hab noch nie erlebt, das bei Blizzard was reibungslos am Anfang läuft.

1 Like

same. I press play, it sayts Launching, then goes to Playing now, and nothing pops up, then returns to Play. :pleading_face: idk what to do.


Exactly same situation here…
I tryed.

  1. relogin
  2. restart pc
  3. change region , change languages
  4. unistall and clean install game again.
  5. unistall and install battle.net

Same here… perfect lunch Blizz!!

1 Like

Same here …click play and nothing just a black screen

1 Like

same…i tryed all…not lunching :frowning:

urg, my sister who lives in Holland - I’m in DK - can get into the game. :pleading_face:

hey guys i had a similar issue, hopefully it’s helpful to you guys and works, but my resolution had changed to an unsupported resolution, so i went into my monitor settings, changed it to a resolution supported by the game and then it worked for me, hope it helps (1280x720 i do believe ) hope it helps

1 Like

Same thing here…Tried change resolution as deadlyblades said,didnt work…U had so much time to make the game be playable…u knew alot of people will play it at the same time…And at the end nobody can play it…Typical blizzard…

1 Like

Sweet, i am not alone, and as far i can say, no need to worry about, no one can play anyway :slight_smile:

1 Like

Moi d2r sur console impossible de me connecter sur une parie il me dise que j’ai pas de connections ou que le serveur est inaccessible

Lucky… i have nothing.

where we can find the people from blizzard, we want our rights, we want a discount on diablo 4, for 0 servers, nobody talks to us, they don’t care, where are our excuses and money…

Same here … not launching at all

Did someone install it on C with the same issue? I’ve installed on a different drive and Im wondering if that would be the issue.

The same situation, doesn’t launching

i have it on c cant enter the game

works only to those vaccinated…:))))))))