Starcraft 2 startup suddenly slow

Hi there,

Since today starcraft 2 is starting up extremely slow. It used to start up in about 2 seconds, now i’m waiting 10 minutes, just seeing an annoying loading bar going left to right. I tried scanning the files, no difference. I changed 2 things in the past few days. 1. I uninstalled starcraft 1. 2. I started playing SC2 campaign. When i check taskmanager it just seems to do nothing. only 2 gb of 16 ram in use, almost no cpu and disk activity. It seems its just waiting for something.

9 Likes

I have the same issue . After i let the game download fully it started to take ages for initial load up. I used to play with the minimum required files and it launched in 10 seconds ( probably less) i did not let it finish for few days the full download, but now as it finished it takes more than 10 min to start up… witch does not make any sense

1 Like

Same issue here. Absolutely unplayable.

1 Like

Same here. Not able to launch the game (SC2) as of today (5 Aug 2020)

2 Likes

Same here, since this morning. Playing the campaign, the missions started to load REAL slow… And when I tried to restart my laptop, the game never really started up again. Just the loading bar bouncing left and right…

same here :frowning: but i have this problem about a few days.

I’m waiting 42 minutes and still nothing…not the first time this year…please do smting…

Same problem here. Please support, fix it.

Same here! I’ve launched files check but it didn’t help. So I tried to reinstall the game and it stuck. So tried to reinstall battlenet - it also STUCK!
Now I can’t play any blizzard’s game!
What a heck is going on here??!!

i got the same problem. I restarted game settings, reinstalled the desktop app+sc2,went into some settings and tried all the options. now i see it is not only me

Well, at least i’m now alone :slight_smile: I just start and i do something else for a while, eventually it loads. Now lets hope someone from Blizz actually reads this…

Same here! :frowning:

Well, today it was magically fixxed! Only had the load screen for 2 seconds, which is still 2 seconds more that it used to be, but its acceptable :slight_smile:

It is working now, after a minute or two…

cant start the game about 3 days tried the fix it nothing works for now

In this case there does seem to have been a problem with an issue occuring with the latest update. We have passed on the information to the developers from your reports, and it is being looked into, there’s no current ETA sadly.

I’m unable to play game at all, every time I try to log in it keeps saying battle.net is under maintenance try again later, this has been happening since I uploaded game to my new laptop at beginning of august.

I solved the long lasting windows buffering tab at launch by adding a rule to open the tcp port 3724 on my firewall

is this fixed yet?
as of today I cant start the game unless im offline!

Same issue here, as of 28.09 sc2 startup time is like 10 mins, also during first 2 hours of play missions load like 3-4 mins and there are frequent stutters both online and offline play for 3-5 seconds. That’s totally unplayable!

Why still no answer from devs in this topic, while it’s here for 3 months already?
Tried reinstalling killing all the remains/caches in all folders both battle.net app and sc2. Tried updating to latest drivers and windows updates.

And that’s taking so long i7-8700k + 16gb + ssd hardware + 100mb/s link(11meg/sec download).