Cannot start game


Today when I wanted to play, I couldn’t use portal or go anywhere from town.
Game would freeze, sound playing but display frozen. Alt+tab and ctrl+alt+del wouldn’t help. Only start menu would be usable.
Reboot or logout from windows was only help.

After a couple of times, game refuses to start. Frozen on Diablo logo before launch. Only kill from task manager helps.


Stacks from process Hacker:

I tried verifying game files, running in 32-bit mode, running in windowed mode. Latest nvidia drivers, tried changing realtek sound drivers to windows stock ones.
Nothing helps


Same here. Could play for a week and then the game crashed ingame today and i wasnt able to get it running again, i tried everything there is for the whole day. It will just crash either when the small logo is shown or itll sometimes siwtch to the fulklscreen but that will stay black and crash too.

I installed the Razer Stuff and voila the game would start, who wouldve thought that something i dont even use would be the reason. But now it freezes whenever i want to start a new game or if i want to switch the character… soo yeah.

Update2: After installing the Razer Stuff and reinstalling the game its working again. Good Luck.

Same for me.

Yesterday I was playing without any problems.
Today the game froze the first time I tried to enter a rift. I killed it from task manager and started it again several times, but it would always freeze on entering a rift.

I reinstalled the game and now it freezes even on entering the town.

Have you guys recently upgraded your nVidia drivers? If so…

Hello Szubster!

VMware is known to cause stability and connectivity issues, and it’s running in your MSINFO. Disabling or removing this would be advisable.