Can't connect to Blizzard Server today

Hi there, never had this problem before. I am on PC, Europe, I have logged into Battlenet hub and attempted to launch Diablo 3 as normal, when the authenticator screen appears, it doesn’t give the green tick as it normally would when it should connect to a Blizzard server. It then hangs for a a few seconds and gives an error I think 1001 and Error 2 taking me back to an unpopulated user name and password screen. When I try to manually enter user name and password, same thing happens.

I have been playing without problems until today, internet is working fine, I have reset PC and router, cleared cache, and renewed IP and flushed DNS etc. this morning but still nothing working. I haven’t changed anything since I last played a couple of days ago and have checked my firewall and anti virus settings but nothing appears to be blocking it.

Any useful tips much appreciated.


Have you tried to temporarily remove the authenticator from your Blizzard Account ?

Hi Boubou, thanks for responding. Sorry if this is a stupid response, im not very technical. To be clear, i dont have a separate authenticator. Its the screen that pops up when game first starts, and it runs throught the checklist, 1. Connecting to a Blizzard Server, 2. Autheticating credentials, 3. Retrieving hero list. It fails on the first one, cant connect to a server and i get either error code 2 or error code 1001. I think it must be some setting blocking connection, but cant think what ot would be. I am going through and disabling things one at a time, but no luck. Been trying all day.

It definitely sounds like something is interfering with the connection.

Something you can try is switching regions and seeing if you can connect to say the Americas or Asia. If it lets you connect to any other region, then it is very likely a network or connection routing issue.

In those cases the following should help:

Try doing an extended power cycle on your system. Turn off all devices including the modem. Wait 30 minutes, turn on the modem, wait 5 minutes, turn on any network devices, wait 2 minutes, turn on your computer and try the game.

You can try switching your DNS settings to use a free public DNS servers instead of your ISPs Servers:

We do not have individual steps for specific modems or routers so if you need assistance accessing or updating the devices, contact the device maker/provider.

Sometimes firewall or routing software/hardware will have some advanced settings to prioritize and manage types of network traffic. Normally that is not an issue but we have seen situations where it can interfere with the delivery of the data for our games/voice chat.

Let’s try turning off these features:

RoG (ASUS Routers Only)
Security firewalls (Some ISP provided modems)

Not all devices will have these options and the steps for turning these functions off will be different depending on the make/model/software version of the devices and programs involved. If necessary look at the documentation for your security and routing products to find out how to turn these options off.

In some cases there is a corrupt or misconfigured setting within the router or modem. We cannot say what that might be offhand but the easiest way to resolve these conflicts would be to factory reset the router and/or modem.

You may need to look up your specific model for the steps on how to do this and in some rare cases you may need to have this done by the ISP. Feel free to reach out to them for assistance if necessary.

Some folks have reported that a VPN gets them around the issue. Please note we do not support VPN usage though we do not prohibit its use with most of our games. Some countries around the world, do restrict VPN usage so you will want to research these restrictions for your country before attempting to use a VPN.

Many VPNs offer a demo or trial version of their service to allow you test without commitment.

If a VPN solves the issue for you then the issue lies with your network, your ISP, or the path they send you through to get your data to us. You can work with your ISP in these situations to help them hunt down and address the routing issue.

1 Like


Thanks for the response… looks like I misunderstood what you meant. Sorry !

1 Like

Thank you for the response and advice. Just to add, that i managed to get into the game after changing the DNS settings, but within seconds of game starting i got an error 1016.

Not able to connect to other regions, same happens.

After trying persistently, i have managed to get into the game and have completed a rift and still connected. I have bee switching off various things systematically, but it seems the DNS changes have worked. Not sure why that should have suddenly interfered as i have not previously had any issues. I will post an update if i have further issues, or if i can confirm details of what fixed things for me

UPDATE within seconds of posting, game froze and i was kicked with error 1016. So i am now able to connect and get into game briefly but not for long. I am currently doing a full power cycle of everything as advised, will report back.

As an update, i completed a full power cycle several times but still not connecting again to battlenet servers again. I have tried to disable the ip6 as some suggested and manually entered DNS options 1 and 2, but just cant get back into the game. Never had this issue previously and havent installed or changed any settings prior to this issue starting last week. Sometimes when the game fails to connect and i get the error 1016, my internet drops completely for a few seconds, not sure if that information helps.