Diablo III was unable to initialize d3d. Click ok to retry

Hello! My friend gifted me diablo 3 and the game runs really crap. I do got 60 fps and not dropping (v-sync) but it studders like no tomorrow. I have tried so many solutions that I cant keep track anymore but the problem still exist. I guess the problem is because of the error I get “sometimes” maybe 50 out of 100 times (Diablo III was unable to initialize d3d. Click ok to retry.) When I click retry it starts the game.

Solutions I tried:

Power mode is set to performance (only using cable not battery)
Tried the windows 8 and 7 compatible mode
Tried re-install PC
Tried playing diablo 3 in windowed and fullscreen mode
Turned off sound ingame
Tried the 32 bit client
I used DDU to install new grafic driver (also tried without before)
Windows 10 is up to date
Turned of xbox gaming bar
Turned on and of v-sync (stop studders for like a min or so when turning v-sync back on)
Temps are under 75c (so no throttling)
Min and max processor state is set to 100%
PhysX is set to my GPU not HD Graphics
Diablo 3 is set to use my GPU when it comes to 3D settings in nvidia control panel

Here is my hardware

Laptop: Asus ROG GL552J

Pics down below in links

Side note: my monitor doesnt have hdmi output so I am using an dvi converter to hdmi and a brand new premium hdmi cable to laptop. (can the converter be the problem) monitor i havent touched so it aint clocked its running 60hz

Is there anything in geforce experience that can cause this? btw my internet speed is 30/1 and ping ingame is 20-50 mostly, maybe something about internet? I do run wired cable so not wireless. And battle net and diablo 3 is installed on my C: ssd not D: ssd, bot got alot spare of storage left so no disc is nowere near full

Heres a series of pictures of my hardware, temps etc

https://imgur.com/a/lagZ3wD

Heres an report of my DxDiag

https://pastebin.com/YZa6wAmf

Heres an report of my re-installed DxDiag

https://pastebin.com/tnasdEPt

  1. Copy the URL to the clipboard
  2. Paste the URL into your forum post
  3. Highlight the URL in your post
  4. Click the </> button in the editor
  5. This will turn your URL into pre-formatted text
  6. Whilst not clickable, the URL will be properly formatted so others can copy / paste it like this… http://www.ThisIsAnExample.com/HowToMakeLinks.htm

This is also explained in Writing an Effective Post in the stickied Welcome To The Technical Support Forum! thread at the top of the forum.

So like this? updated the post

Indeed. But when I follow those links it gives me this…

That page doesn’t exist

The requested page was not found.

I’ve seen the forums have problems before with the image hosting site you used. Try uploading to… Imgur: The magic of the Internet …and it’ll build an image album. You can then post a link the album (which will contain all the uploaded images) or you can post links to the individual images in the album.

Hmmm…? I can see all 4 images.

Usually, failed to init d3d is caused by outdated drivers. Your screenshots doesn’t contains the version number/date. I can’t check for you. Better to save the DxDiag report as text and paste the report between two “~~~~” lines, like this:

~~~~
DxDiag report
~~~~

Please update drivers from the GPU/Audio/… manufacturers; DON’T relies on Window’s update.

If you have some Razer products, please read this: Known Technical Support Issues - [Updated Dec 14, 2019!]

This is a troubleshooting article of D3D init error. Skip the steps you have already tried. Click the blue text for more details.

If problem continues, please include the DxDiag report in your reply. If the file is too large, please upload to some sharing site, such as pastebin.com, and put the link in your reply.

Thanks, I got latest gpu driver and audio, downloaded gpu driver from nvidia and audio from asus site with my laptops number. I will try that troubleshooting, here is a link with all my pics, there u can see driver for gpu, seems speccy show one driver and msi after burner another, i dont get it

https://imgur.com/a/lagZ3wD

Heres an report of my DxDiag

https://pastebin.com/YZa6wAmf

Heres an report after my re-install of DxDiag

https://pastebin.com/tnasdEPt

Now I dont even more then I have before, see any problem?

Need support to take a look at your DxDiag report. If support doesn’t response here, you can input a ticket together with the report.

For Intel HD4600, your driver is dated 2016. You may check if Intel has a newer driver.

Your sound driver is dated 2015. Check if any newer driver.

Check your Nvidia settings to ensure it uses the GPU for D3. Sometimes the computer uses the HD4600 instead.

1 Like

I found an update from Jan this year to HD4600, didnt help. Uninstalled all sound stuff because there wasnt any new and I dont use any sound when gaming (having discord, music etc on phone) I also tried another monitor to see if there was a problem with my dvi to hdmi converter, didnt help and same for laptops screen. This pc freaking sucks zzz

As you have mentioned discord, make sure its overlay is disabled. If you have other softwares, e.g. GeForce Experience, disable their overlay options as well.

Also try testing with anti-virus disabled temporary.

Uninstalling sound driver might not be good idea. But I’m not expert.

If you don’t want sound, just turn the volume down or use mute.

I still recommend you to input a ticket to contact support directly. They know much more than I do.

I said I am using discord and music etc on phone not pc :smiley: yeah I got no anti virus or firewall. okey i will input a ticket, thanks for trying to help mate

Hi there Damposd3

Do you also have your MSINFO? I didn’t see that in your posts.

Here’s how to collect your system files then do the same as you did with the DXDIAG.

Hopefully the MSINFO can shed some more light on the issue for us! Sorry no one replied before now.

https://pastebin.com/kebespzd

Theres my msinfo, did you see the errors in DxDiag?

Really sorry for the delayed reply there, missed your notification somehow :(.

It might be worth reinstalling your Graphics drivers. Remove them using this tool: Display Driver Uninstaller Download version 18.0.6.0

Then reinstall from the manufacturers website.

That should fix this now.

Sorry if this is a necrobump, but does your machine have hybrid graphics? My old ASUS ROG G550JK had Intel HD4600 + GTX850M, and I had to set the Graphics Card that the game uses specifically to be the GTX, instead of the Intel HD Graphics. I believe you can do this under the Nvidia Control Panel, under the "Manage 3D Settings’ section. Choose Diablo III and there should be an option there to select the GPU to use. You could also just right click on the Diablo III Exe and choose the option to run it with the GTX.

I hope this helps!

Before click play … In setings change from 64 bit to 32 bit version and it will run … was same problem here !!