Diablo III Won't start (gray screen) [solved]

Greetings, my friends,

I did a fresh install of d3 yesterday on a windows 10 (2019 i played on this pc with win7). When pressing play the game just showed the ros logo forever. i tried a lot. Since I cleared Blizz entertainment cache the game lives for 20secs longer and i get gray screen, but nothing happens again and I have to kill it.
until now I tried:

  • Fresh install of bnet and D3
  • bnet and agent cache clear
  • running as admin
  • 32bit version
  • fiddled around with D3Prefs.txt
  • chroma disable
  • windowed mode
  • reset prefs
  • gave any possible security-permission I know of to bnet and d3
  • disabled firewall and Antivirus
  • waited for 15minutes
  • killed the agent
  • reinstalled Drivers (RX570) but no DDU yet
  • msconfig - disabled all non-win services
  • setting shared memory to 4095

And as far as I know i never owned anything Razer Chroma related. Thanks in advance. I hope someone can help me.

  DxDiag (https://pastebin.com/AQua2skB)
 MsInfo1 (https://pastebin.com/kiBceuB2)
 MsInfo2 (https://pastebin.com/DmJFBBym)

Hi:

Have you tried updating the video card drivers ?

According to the DxDiag, the drivers installed on your system are dated 16 Aug 2019; the AMD Drivers and Support site shows drivers dated 29 Sept 2020 as being the latest.

See : https://www.amd.com/en/support/graphics/radeon-500-series/radeon-rx-500-series/radeon-rx-570

now that i think about it, yea, i only tried installing older drivers to test and did not look for an recent update - gonna try that right now


edit: unfortunately updated driver didnt help. everything seems to be the same as before.
logo -> gray screen -> cpu usage goes up to 70, loading ~642.000k into memory, then falls to 0 cpu and goes unresponsive

OK… I’m sorry that didn’t work. Hopefully, a Blizzard CS rep will have other suggestions for you in the morning.

i tried to start it again today and it had the same problem.
i waited 10min and when i came back i noticed D3 was switching between “inactive” and “running” in taskmanager using 01 cpu occasionally. Then I tried the Win+P switching between modes to ‘redraw’ the image and it worked.

Doesnt feel like a real solution though, but maybe that gives some intell about the underlying problem?


edit:
“it worked” was a bit enthusiastic … i can see my chars, delete old ones and stuff but could not play any of them or create a new one since the game gets stuck as soon as i try. Game is labeled “inactive” in taskmanager using 1 cpu …

interestingly I don’t get the grey screen anymore - straight through login to characters.

Hi again,

You may want to do a ticket directly to Blizzard Support if you do not get a reply from Blizzard soon… use the following links:

and click the Contact Us button at the bottom of the page.

Hi again,

This is a far shot… but take a look at this post on the US Tech Support forum from a player in Germany :

He had the following problems before using the VPN :

  • game did not start (either Logo then freeze or greyscreen then freeze)
  • endless loadscreen then freeze
  • random freeze while playing

Same issue there but only on PTR.
On the “Normal” EU servers can make games…

Your crashes aren’t just restricted to our games it seems.

  • Please go to windows search
  • CMD
  • Right click CMD.exe
  • Run as admin
  • Enter the command:
  • SFC /SCANNOW
  • Allow it to run.

Your drivers in the MSINFO are quite out of date, and while you say you’ve updated, make sure you update them, but do a clean install:

https://www.amd.com/en/support/graphics/radeon-500-series/radeon-rx-500-series/radeon-rx-570

You have a tablet device active by the looks of it. Tablet drivers are know to cause crashes and conflicts with the mouse/KB in games. It might not be playing nice with the recent window update. Discord overlay can also cause issues.

  • Press CTRL+SHIFT+ESC
  • Startup Tab
  • Disable everything except OneDrive and Steam
  • Restart the PC
  • SFC /SCANNOW found nothing

  • I Safemode deinstalled gpu-driver with DDU and installed 20.9.1 driver (9/16/2020)

  • deactivated everything but steam,Onedrive and avast antivirus(could not toggle it off)

Game behaviour: super quick load into character screen, fast and responsive until i want to play. Then I see loading screen with moving loading bar for 5-10secs then gets stuck.
or when i choose a character and click “create character” it gets stuck before loading screen.

New dxdiag and Msinfo:

dxdiag: pastebin.com/s34NuZKA
Msinfo1: https://pastebin.com/7HU70U5x
Msinfo2: https://pastebin.com/zGKcLH5D
MSinfo3: https://pastebin.com/yAb7Tayt
Msinfo4: https://pastebin.com/RwkCWbZb

edit: oh and i tried deinstalling anything related to the tablet and disconnected it


EDIT2 my ‘solution’:

At this point I Reinstalled the game again - logo gets stuck and cpu falls to 0 but after some time I noticed in ressourcemonitor the game had some networkactivity again -> i press win+P -> I get gray screen and cpu goes to 70 then goes down to 0 again but process in network after some time again becomes active -> win+P -> i get the character screen, and i press “continue game” and get loading screen -> again goes unresponsive after 20secs i wait a bit again and press win+P and it comes back to life but then loaded for ages (i get new texts and loading bar is moving and the game doesnt hang) … after 15 minutes i kill it though … restarted the game and loads straight through everything without any problem. like it only needed the extra kicks at the right time on the very first startup.

I got to create a new character and got a world loaded up for 30 mins now playing. soooo success i guess?

Tldr:
so for me it was: On first startup after install give the game ton of time to load even if taskmanager says its dead and look into ressourcemonitor wether the game has some networkactivity and then try to Win+P to get it unstuck and to the next stage.

maybe this helps someone but this seems to be a pretty unique case.
Also i dont know which part of my old drivers and everything else i tried was part of the solution too!
gl peoples.

2 Likes