Game freeze after 5-10 seconds

hi, i installed the game after years on a new laptop and it freeze after a few seconds, i can move the mouse but nothing else. cant switch tabs(if i do the diablo screen turns grey) , only window key works. If i open task manager i cant select it.
I tried multiple solutions found online(driver,energy options ect.) and repaird the game, so far nothing works :frowning:

pastebin.com/BaUVxu16  dxdiag

pastebin.com/dyyWPzJZ msinfo

pls help :frowning:

3 Likes

Hello Hostahorst!

Please update your drivers and operating system:

Check for errors

And if the issue persists:

  1. Go to windows search
  2. Search “Game Bar Settings”
  3. On the Game bar tab, turn OFF: “Record game clips, screenshots and broadcast using Game bar.”
  4. On the Captures tab, turn OFF: “Record in the background while I’m playing a game.”

It can be turned back on at any time by reversing these steps.

Hi,
I get the same freeze on random periods of time
I installed D3 and D3-ptr the same way
D3 work perfect for hours
D3-ptr … well… its a struggle
Blizz why dont u fix ur servers instead of blaming drivers and file errors!!!

Thanks for the advise, unfortunatly nothing works so far. If i join a game after a few seconds the game still freeze and i have to sign of windows. Did all things possible so far. Installed every windows update, chipset drivers ect. Did clean installs of newest graphic drivers. Window mode, repair, new install of D3. Switched multiple settings in game/ drivers, changed Power settings, deleted the d3 file. Did the Chroma thing… nothing helps :frowning:

That can happen if you are on Win 10 2004 build. Install Win 10 (build 1909). Blizzard doesn’t want to update the sound .dll file used by D3 for Win 10 2004 build

The funny thing is, i had the same problem with the 1909 build and updated later to 2004 :confused:

Do you have GameBarPresenceWriter.exe process in the background? Try ending it when you start Diablo 3. See if that helps.

Now it´s working. Thank you so much. Finaly, this issue was driving me crazy^^

Turning off the game bar as suggested should have worked, perhaps it requires a restart to prevent the gamebarpresencewrite.exe from running for that login session. :thinking: I’m glad it’s working now though!

Turn the Game Bar stuff off…

Start
Settings
Gaming

Game Bar
Record game clips, screenshots, and broadcast using Game Bar

Captures
Record in the background, while I’m playing a game.

^^ Disable those.

The problem is even if all those options are disabled GameBarPresenceWriter.exe can still be running in the background. Don’t know if it can still cause any problems even if inactive though.