Razer Chroma Issue

Hi guys, bit of an odd one here. I used to have a load of Razer stuff a year or so back that worked wonderfully with Diablo 3. I’ve just been gifted some new Razer gear and found Diablo’s Chroma effects are not working?

I have been in touch with Razer who advised making sure I remove everything (all their software etc) and reinstall it, I have also removed all diablo 3 files and reinstalled but to no avail. The game still doesn’t affect the lighting. The chroma apps/effects do work for other games though such as Doom (2016) and Overwatch.

Does anyone have any idea what might have gone wrong or ways to solve? Any help appreciated!


Are the Chroma effects enabled in your D3Prefs file ?

Open the D3Prefs.txt file in Documents\Diablo III with Notepad or similar text file editor. Check that you have:
DisableChromaEffects “0”
DisableChromaEffects “1”

Disabling Chroma Effects used to be one way of solving issues between Diablo III and Razer devices.

1 Like

Yup showing as 0 not 1. Should there be a file in the Diablo 3 folder that refers to Razer/Chroma etc? I can see a .dll which references CUE which is the Corsair lighting software but nothing for Razer? Have tried scan and repair too.

I don’t know… I don’t have/use any Razer devices.

One last thing you can look for… one used to be able to disable Chroma on specific games in the Synapse software… I guess you should check that D3 is enabled.
Also, bear in mind that D3 comes in 2 flavours:

  • 32-bit : C:\Program Files (x86)\Diablo III\Diablo III.exe and
  • 64-bit : C:\Program Files (x86)\Diablo III\x64\Diablo III64.exe

That’s about all I can think of at the moment…

I’m surprised none of the forum support agents has stepped in yet… :frowning:

Hey, so I tried Boubou’s fix but that didn’t work. What I did was go into the D3Prefs file and changed
DisableChromaEffects “0”
DisableChromaEffects “1”
then restarted the game. That worked for me.

you don’t happen, to have found a solution, I have the exact same problem as you describe

I’m having random issues with my Razer and D3. I had to completely disable the Chroma effects while playing D3 otherwise the game won’t even start… It’s so random, sometimes it works sometimes it doesn’t.