Error on load-up after today's update

After having done the update from the android store, the game gives an error message when loading up saying:

“An update is required to play hearthstone, but it is not yet available in the store. Please check again later.”

Is anyone else experiencing the same issue?


It is all the same over here

Same issue for me, same message

For me too. Over an hour now.

Same here. It’s so silly.

Same here, Google Play Store Austria

Same here - english - trying to play on Samsung s20

Same here, update all from google play didnt help

I had this issue.

What fixed it for me was to uninstall from the store and then reinstall. After launching once it was reinstalled it patched then the app hung. After closing the hung app and reopening it worked properly and is now installing the new update correctly.

Hope that helps someone.

Same in the asia pacific area (Australia). Looks like they stuffed up the version number in the update so when it checks it thinks its an old version.

Same thing here, but i don’t feel like reinstalling the game.

1 Like

Same here, pretty annoying.

Same, have tried the workaround of updating all apps, but the issue remains.

Anyone have fix this problem whitout deleting game?

Android: Long press to bring up App Info. Clear Cache and Storage. Takes some time to download but at least worked for me.


Thx. Clearing just the cache worked for me. It redownloaded a small 50mb update and is now opening

Hey all,

Thank you for the reports!

We’ve recently made some changes to help prevent this situation and just restarting the app should sort it out now.

If anyone is still having issues, try clearing the cache as described by sLipad above or a fresh re-install should take care of it as well.

Thanks again for letting us know and for sharing the solutions you found already!

1 Like