Hs:ngresult db error:303:0

Previous threads are closed and I have same issue today for couple of hours. Playful spirits and code is thrown: HS:NGRESULT DB ERROR:303:0.


I’m have same problem

I have same problem. I trying it about 1 hour.

I am also having this same problem. Day2, i sure would like to login and purchase the new set.

Same here. Reinstall didn’t help

same problem with eu server… ok to other server

Same problem here. Both on my iPhone and my MacBook.

I also get the error when i try to start the game. I am on the eu server.

Same issue here. Previous post posted no solution.

At least an announcement would be helful!..

same here, android
no login possible…

same here macos + ios (been happening since last night)

They did say to wait :smiley: I am waiting second day now.

I have the same issues. On EU servers only. Tried multiple devices.

"Hey all,

We have received more reports of this error affecting certain accounts after patch 23.4 released. Our Hearthstone team is investigating the problem in order to find a resolution.

As mentioned previously if you haven’t already please submit a ticket to report if your account is affected. Please also include the region you are accessing (Americas, Europe, Asia) as this error tends to be region specific.

Thank you for your patience while our teams work to get this cleared up."

copied from us forum


It have been 3 days and still no solution… I miss hearthstone… :sob:
I’m forced to play diablo instead :grinning::grin:

Same problem here, finished a heroic brawl just before the New miniset would be released, but closed the game ( a man has to eat :slight_smile: ). Since then same error as everyone else above. I play on EU, mostly on my iPad. I can login on US on my iMac, not on EU ^^. Plz fix this, weekend is coming!

i just got a ridiculous answer to my ticket :man_facepalming: he sent me to a support website, which doesn’t have to do anything with our problem and wished me a fine day…
so waiting for another day to get a new answer, that doesnt help anything…

Yeah same here. They completely ignored the actual point.
They claimed that I asked for password reset (which I didnt) and asked me to go ahead and try that and then closed the ticket…

you could have used the option “problem still exists” or something like that, to send another ticket, so did i, when i got that very professional answer to the problem