IS there a way to fix this

i have had this message for almost 2 months now and cant fix it no matter what i have tried
Your game timed out as it was requesting data from the hearthstone utility service please relaunch hearthstone to reconnect

and top the screen read HS:CT;netcachedecks=0;netcachecollections=0;netcachecardvalues=1

this only happen in the EU but well that where all my stuff is

1 Like

Hey RyanBell!

You may want to try deleting the cache folder to solve this.

Let us know if it worked!


thanks but it did not work

I get the same msg trying to log on to EU on my PC. Every other region and the mobile app on EU is able to connect.

1 Like

guess we are both out of luck then

Just starting having this problem on NA yesterday. It let me login for a few hours after the first time, but today it’s not letting me login whatsoever. Tried everything. Now after I’ve uninstalled it multiple times, it’s not even letting me install the Battlenet app anymore. Has anyone found a solution yet?

1 Like

This is happening to me too. Happens on all regions.

Tried all fixes. deleting cache folder, reinstalling app, reinstalling hearthstone. None work.

Same problem here, can’t log in for 2 days already! None of your fixes are working…At least give us an update or something?

I removed all Blizzard/ folders in



and now it works. But it does reset all settings.


Download - emptystandbylist (watch a youtube tutorial) then watch the magic happen. Windows 10 doesn’t release bank your cache build up ever since I did this I’m running again. It’s been almost a month of trial and error.

This sorted all my issues out for me…windows 10 doesn’t bank or release cache…you can check this out in Task Manager under perfomance tab for your memory…no dev help, no hearthstone answers, I swear, there is no real assistance from them. Sorry guys but all your threads and advice don’t cover all the bases. I don’t expect it too but I’m a complete pc novice and stumbled onto this with little search engine inquiries.

Hello. Same problem here. I can’t open Hearthstone on my macbook pro os High Sierra 10.13.6.

It crashed a few times on Saturday afternoon (15/01) and I can’t open it since. It starts opening and then It says “your game timed out as it was requesting data from the hearthstone utility service ”.

I tried opening other games, like Heroes of the Storm. No problem there.

I also tried to log in with a different account and open Hearthstone and it worked fine!

I tried several fixes I found at the forums like deleting the game and all files and reinstall the game twice and it didn’t work. I also deleted the Bnet App and reinstalled it. I tried every fix I could find. Nothing worked…

I started thinking there is something wrong with my account, but it works just fine on other devices.

Finally, I tried contacting the support, but I couldn’t submit a ticket.

Please get back to me with an explanation and a solution.

Thank you.