Merchant Cart is disappeared

Merchant cart is not avalaible. Packs cannot be opened and quest cannot be completed.
When it will be repaired?

1 Like

You say it was in your village and dissapeared?
I’ve encountered some glitch that the whole game became unplayable. After Windows restart, it started working again, so maybe try that.

Windows restart was not helpful. It still not here. And it wasnt here.

Well, if it was not there, have you built it in the Workshop?

I have the exact same issue, I built the cart and crashed at the same time, now the cart is gone and the workshop is full with no option to build the cart.

Hi all,

We’re aware of this issue and still working on a solution.

For more info and updates, please keep an eye on the thread here:

Thanks for your patience for now!

During the launch of Mercenaries I couldn’t validate the task of building the travel point. When i relaunched the task was done but the next building (merchant camp?) is not available. It has been like this for 3 days, I can’t finish tutoriel or open packs, I was eagerly waiting for this mode and now I’m stuck with 6 basic mercs and can’t do anything with them, this is extremely frustrating.
Please fix this.

1 Like

same for me 2 days later

Just want to say , that the issue still exist.

I start recently and i’am stuck

Me too, I can’t build the merchant camp, and cannot finish the tutorial or open packs. Can this be solved?

here too. can’t get the merchant cart to continue the tutorials.

I am also having the same issue.

Frustrating… still waiting fix for this… no reason to play before open packs…

i have the same issue, trying to get the new mount shared with wow but cant open the tutorial pack :frowning: