Updating Android App, Impossible Over WiFi?

Updating over WiFi… Something I’ve been complaining about for years now on the Google Play HearthStone App page, where users can leave comments for the app owner/developer.

After the latest update this early in April, I’m already out of bandwidth for my cellular plan for the rest of the month.
Because for some reason, when connected to WiFi, the game can’t get update data.
Only when you switch to cellular, the update starts downloading. When you switch back to WiFi mid-download, it stops and “acts” like firewall settings are blocking the download? It says it can’t connect.

Not due to any modem and/or router settings on my end (I think), because:
I have no problems updating on my Desktop PC (with which I also connect to the internet using WiFi)

  • My other (mobile) games & apps update just fine over WiFi.

Of course I’m not asking you guys to pay for my extra data plan that I had to get in order to get through the rest of the month… but if you take a moment and think about it; why shouldn’t I in all honesty?

I’ve seen replies to other comments made on the Google Play App page, so it’s not like you’re not taking notice. I know for a fact that I’ve been leaving app reviews about this as far back as at least 2016. Could you please fix this once and for all?

Thank you

1 Like

Heya DeFactoFrank,

Hearthstone should download without any issues over your wifi. It would seem likely that this is an issue with the wifi configuration where Hearthstone may be blocked from getting the updates or you have managed to block it’s access to update over wifi on your Android device.

There are no known issues with Hearthstone that should cause you to be only able to update on your mobile data.


Since I’ve had this issue since 2016 at least, it -in my case- means I’ve had this issue across multiple devices; a Sony Xperia Z3 Plus and 3 Samsung phones (an S7 Edge, S10 and S21 Ultra respectively).
I’ve tried factory resetting the S21 Ultra that I’m currently using, so it would appear that, following your explanation, HearthStone updates over WiFi might be blocked out of the factory?

That sounds highly unlikely to me, to be honest.

Would there be any troubleshooting steps which I could follow that may identify an issue with the updating connection? (Technical steps included)

I have not altered the DNS settings, nor am I using a VPN for playing online games (I’ve tried updating/playing HS without any VPN installed after the factory reset, so any config added by a VPN are not the culprit either).

EDIT: To add I would like to clarify beforehand that I’m not the kind of person that installs all sorts of random apps that would ‘corrupt’ my device’s daily usage. Nor would I ever in this day and age root my mobile device or flash a custom rom.


I’m sad to see that you didn’t get any answers here as I have the same issue…

1 Like

I dont think I have ever been able to update HS over WiFi… Regardless of the phone or wifi network.