Add and Remove application is showing an uninstalled game, how to fix?

My windows Add and Remove applications shows that i have Heroes of the Storm installed and it takes up 48,9 GB, that being said when i press remove, nothing happens and an error pops up through the blizzard launcher informing: BLZBNTBNU00000006.

The uninstall file is still being shown in the Add and Remove Application window, and i stock there.

In the Blizzard Launcher Heroes of the storm is set to be uninstalled and there are only an installation button, not a Play button available.

I hope somebody can help me so i can get windows to see that the game is 100% uninstalled since i am unsure if the computer thinks that it has a 48,9 gb installation on the harddisk, which is actiually not there?

Hello L8rS8n!

Removing an entry from the Add/Removal programs tool is a bit risky as it required editing the Windows Registry. We can’t guide you with that, but if you want you can follow this Microsoft guide.

Just keep in mind that messing up with the Windows Registry is something you’ll do at your own risk.

If you are looking for a safer solution instead, your best bet would be to simply reinstall the game, and then uninstall it via the Battle.net app. That should also remove the entry in the Add/Remove program list ^^

Does not work, i have tried to remove it with Battle.net. However, this never works properly (as always with Blizzard), I cannot remove the following games; Call of Duty Black Ops 4, Destiny 2, Diablo 3, Heroes of the Storm, World of Warcraft, and World of Warcraft ‘Classic’. Nevertheless, it will not uninstall through either Battlenet launcher and Add or Remove Programs

I’ve had a similar issue when I tried to delete Destiny 2 from my harddrive to free up space on it (this was a few months after they split from Activision) I simply couldn’t use the launcer to remove it as it was no longer there. What I can remember I did was that I somehow opened a built in uninstaller for the Battle.net app (Idk if it’s still in the app somewhere) but there it refused to uninstal the game for some reason and gave me an error, the fix that managed to solve it was logging out of the app while still having the uninstaller open to not get an error

I also have this issue, i can’t even install the battle net app anymore and nothing can be removed either

Hello guys. I had a similiar issue with a call of duty beta’s. The thing which helped me, is to uninstall battle net and then delete “battle net” folder in C:\ProgramData.
Then go to control panel and choose “Programs and features”, now you can delete stucked games with no issues.
Hope it helps.