Crash on startup (mac m1 pro, ventura)

Hi, when I try to start the game, it crashes with the following ID during the authentication screen. ID: 969269B6-342E-422A-93B9-9FA6A9377B85
It did work previously today - not sure, what changed. I tried reinstalling, but maybe didn’t remove everything correctly.
Thanks for your help & cheers


Same here. The game launches, tries to authenticate and crashes, mac M1 pro, ventura 13.4.
Worked just fine earlier today.

1 Like

Same for me! Everything with the latest update and my M-Air M1

Same here, I tried the “scan and repair” tool, clearing the cache for both and HotS and reinstalling the whole thing.
Some help from Blizzard would be cool

Same here. Complete reinstall did not do the trick. Hope Blizzard thinks of us MACies!

Same here, came to report this but it turns out it’s a general issue. Hope Blizz will fix soon.

Same issue…cant tell you how much i miss playing! please resolve it soon!

1 Like

The same problem on imac. Please, fix it.

1 Like

same problem played this morning now can’t open game

The same problem on macos m1

Welp, it’s happening for me as well. I’m on an Intel Mac Mini though. Worked fine last night, and tonight it just crashes during Authentication…

Me as well, MacBook pro!

I also have the same problem, I tried everything too, MacBook M1 pro.

Any updates yet? Same issue here.

Macbook Pro here! I did everything i could think of to get the game to run. Did notice a bit of an issue while playing earlier in the day about 12:30 ish. Kept getting disconnected durinf a game but it didnt happen after that, but now i cant get past the authenticator or itll give some error about the region being too busy and to try again later.

Hopefully this gets resolved soon. Glad to know that im not the only one. Thought my laptop was kicking the bucket on me. Hopefully we get an update soon cuz it shouldnt have been a delay in a rwply from Blizzard but yet i see no update as of yet.

Macbook pro 13 m1, same problem, game crashes during Authentication. Reinstalling the game did not help.

same here. Macbook M1 pro

Same here - on the m2 Mac mini

Have same issue on a Mac mini M2.

Seems like Blizzard have somehow broken the MacOs version.

Mac M2 pro here. Same issue unfortunately…