Mouse delay/ not responding in games pls help

Hi Guys

I have encountered a bug that makes my mouse clicks not responding properly in game. For example, if I click move then it ignores my next few clicks and just kept moving to one location. Or after casting a skill the character would just stand and do attack without picking up my click to move. It gets worse during fight but happens even at the start.

Thing I had tried

Windows 10 Disable Scroll inactive windows when I hover over them
Reinstall mouse driver
Uninstall GeForce Experience (GTX970)
In game windows full screen mode
Tick Reduce mouse lag option
Lower graphics setting
Change mouse frequency
Changed power setting
Changed USB port

I have done everything I can find. Any ideas?


Can you please upload your system files to and reply with the links to the files using the preformatted text option to encapsulate the links.


Thank you for the reply. I even tried to reinstall my win10 but it is not helping at all.

I had uploaded my system files and the link is

Please help!

Looking through the technical file there’s a few things that could be happening here.

  • Open the Heroes of the Storm folder.
  • Right click the Heroes executable and select Properties.
  • Click the Compatibility tab.
  • Check the box for “Disable display scaling on high DPI settings.”
  • Click Apply and then Okay.

Second idea

  • Click the Start button and go to Settings.
  • Select Devices then “Mouse & Touchpad.”
  • Click “Additional Mouse Options.”
  • Select the Pointer Options tab.
  • Uncheck “Enhance Pointer Precision”
  • Click Apply then Okay.

It could also be that your mouse is dying, are you able to test with another mouse if the problem reoccurs?

It may also be a connection issue that is showing as a mouse issue, it seems you use a Mobile Network to connect to the internet, if you’re able to use a Cabled connection it could help with this.


thanks for your reply

First idea:

I couldn’t see the box for Disable display scaling on high DPI setting. So here is what I can see

Disable fullscreen optimization (ticked)
A tab to Change high DPI settings, if I click it, there are 2 boxes. 1 Use this setting to fix scaling problems for this program instead of the one in settings. 2. Override high DPI scaling behavior scaling performed by ___. Currently both boxes are unticked. Should I change any of these?

Second idea: I had tried that, with reinstalling my mouse driver and disable/enable Scroll indictive windows …

I only have mouse issues when I am playing HoTs. Currently I have 5 games and never miss a click.

The ping shown in the game is less than 50ms. I will try to find a cabled connection but I doubt it is the issue. It happened before a year back when I was using cabled connection. I don’t know what I did to fix it. If you can think of any other possibility please let me know cause at the moment is unplayable.

Thanks a lot

Sorry for my late reply here I’ve been away for a bit :slight_smile:

So the box you tick is the bottom one “High DPI scaling override” one.

Let us know how it goes!

Hi !

Do you succed to find what was the issue ? I got the problem too and nothing of both solutions works for me. Help is appreciated :confused:

I only got this keyboard delay response issue after I switched to my new logitech keyboard. I was fine with the older keyboard before. I don’t know how to fix this problem… working in progress. Doesn’t seem like there’s a solution here.