New patch broke queuing

Yesterday, no problems.
Today, new patch and constantly get this while in queue:
A problem occurred while connecting to the game. Please try again later.

Not just on my acc or pc, friends also have it. Others have complained in game as well.

Kinda feels like this isn’t the first time this particular bug started. I vaguely remember this happening a few years ago.

1 Like

Same stuff here. Que breaks a lot of times with latest patch.

Ha. Of course as soon as I post, I restarted HoTS and bnet again and now it works… /sh

I see this issue as well. I played a game maybe 40 minutes or so ago, and I tried to queue a second time. This time it said my game was incompatible - so I closed HoTS and it updated. Now when I attempt to queue I either get “You cannot enter matchmaking because your status has been locked” when queuing or I’ll get what OP said: "A problem occurred while connecting to the game. Please try again later. I’ve tried restarting HoTS and the battle net launched multiple times to no avail. I even threw in a PC restart for good measure before coming to the forums.

I’ve been having this all day off and on too. Kicked out of the queue several times before one actually lets me get through. While playing I have no issues of lag or connection drop. It just seems to happen on the Ranked queue phase. Isn’t so bad during the day, but like right now at this hour it’s a 5+ min wait for a game to start… to then have me kicked out of queue for whatever is happening… It’s frustrating. I’ve never had this issue before.

“You can no enter the matchmaking queue as your status has been locked” - the message that pops up in chat. No status locked notice shows up, I can instantly queue again afterwards.

Edit - The message that pops up when I’m kicked out of the queue; “A problem occurred while connecting to the game. Please try again later.”

I’m also having this problem tonight 8:37pm Pacific time. Tried to load into ARAM and QM and whoever was party leader kept “declining ready process”. Then tried playing RANKED solo and said my request was timed out. Currently running scan and repair to see if it fixes it. Scan found nothing to repair.

After i went back in after the scan i could solo q but havent tried party up again.

I don’t know if I am the only one but I have reached the stage of almost being unable to join QM games because of this error. It comes up a lot more now than yesterday.

Can confirm that this is still going on. EU queues can take a really long time and they still end in “Error. A problem occurred while connecting to the game. Please try again later.” Restarting the game after every try very rarely helps and I can enter a game once in a while, but the problem is back the next time I try to queue. I’ve read that this a a recurring bug but I personally have never seen it before and it only started this week.

I have tried reinstalling the app and the game itself, but nothing changed. Does anyone have any other ideas?

I have this ongoing since the maintenance finished. 2 days with random blocks on queue (have te restart the game to start queing again). Sometimes the queue fails because others have the same issue (it says the queue has been cancelled because someone didn’t join) or it fail to connect on my end - sometimes just randomly works. Haven’t seen formal blizzard statement (nowhere, even on twitter) that this is being looked into.

Getting exact same messages here in NZ. Played one game, queued for a 2nd and it dropped me, now I get this message on repeat despite resets.
EDIT: Queued as a different character and it just let me through.

Same here, nobody seems to care

Either ‘someone else has disconnected’ or I get my ‘status has been locked’

Hey folks,

We wanted to let you know that we are aware of these issues are we are actively investigating. We don’t have an ETA we can provide yet but hopefully we will see this issue resolved shortly.