Rendering device has been lost


#1

Game crashes randomly every 5-30 minutes with “Your Rendering Device has been lost” error.
My PC specs are:
CPU: AMD Ryzen Threadripper 2950x
GPU: NVIDIA RTX 2080
RAM: G.Skill DDR4 Flare-X 4x8GB 3200MHz
Mobo: ASRock X399 Taichi
144hz Monitor

I’ve gone through tens of threads following all suggested fixes, upgrading bios, chipset drivers, switching DP/HDMI cables, different monitors, refresh rates, Nvidia control panel settings, in-game options, drivers, even reinstalled windows, etc.

I can’t find many threads about this error on the EU forums, most of them are on the US. I’ve sent a report to techinfo@blizzard.com with dxdiag and msinfo. I see a lot of people have the same problem with the same GPU.

I’ve stress tested the card with multiple benchmarks for hours without no errors. Regardless, I’m still wondering if it’s a hardware issue and I should RMA the card, or it’s something else.


#2

I’m getting this too. And I followed the instructions I found on another thread on the old forums that involved resetting the game to it’s default settings and searching for Windows Superfetch (which I cannot find on my machine at all even after the search using “services.msc”) This wasn’t a problem until today. And I’ve noticed that I’ll crash if I stay in the main menu too long. Once I get in game I can go a few rounds before my game crashes. All my fans are working on my machine so I’m no overheating. And this is the only game this is happening with.


#3

Superfetch has been renamed to SysMain in Windows 10. Regardless, this hasn’t been able to help either.


#4

Yeah I discovered that later. Nothing on their list of fixes works. And I did nothing different with my machine. And it’s only Blizzard games (OW, Diablo 3) that seem to have this issue. No other games I own crash at all.


#5

Hiya,

Could you try and re-install the latest graphics drivers once more for me please? Before installing the new drivers, use a Display Driver Uninstaller to remove the current graphics drivers to prevent the new driver from using outdated files.

Before testing Overwatch, go through the steps to close background applications. If you installed supporting software alongside the driver (for example, GeForce Experience), disable the overlay options and do not use the software to choose game settings for you. You can choose to do this at a later time, but please do not do this before testing Overwatch.


Have a few seconds to spare? Let me know how I’m doing!
https://www.surveymonkey.com/r/Nenyasqi


#6

Did everything, dunno if the Rendering device has been lost error is still present, but after ~30 minutes of playtime - the game crashed with the message: “Overwatch has crashed in the graphics driver. If your driver is not up-to-date, please consider updating them…”

Report ID: 268F2017-5217-4467-AFF8-F676AE96AF3B


#7

Thank you for going through those steps Suparmon.

Please post your System Files so we can have a closer look into this. Please go through the steps listed here, and create both the MSInfo and DxDiag files. Post them on a page like Pastebin.com or share directly with us through OneDrive. Post the links here afterwards as Preformatted text, so we can have a look.


Have a few seconds to spare? Let me know how I’m doing!
https://www.surveymonkey.com/r/Nenyasqi


#8
MSInfo https://pastebin.com/CGUq38KN 
DxDiag https://pastebin.com/4hbw6fND

#9

Thanks.

Let’s start by once more going through the steps to close background applications. After the restart, doublecheck that things like Discord, Steam and EpicGamesLauncher have not started itself up again. If they have, close them completely for now.

In addition to those applications, please stop the MSI Gaming App, MalwareBytes and Wacom Tablet Software. If you have your tablet connected, please disconnect this for now.

Last but not least, enable the Secondary Logon Service and test Overwatch once more.


Have a few seconds to spare? Let me know how I’m doing!
https://www.surveymonkey.com/r/Nenyasqi


#10

Played with every single service disabled and no other applications running, for around ~1h, then a new error popped up - “Application encountered an unexpected error.”

Note that I’ve also removed geforce experience, and I’ve disabled DVR, game-modes and any sort of windows in-game overlays, etc.
Repord ID - “2378C9C7-3E1A-40B4-A9C2-A8352D360F73”


#11

Ok, so after trying many many fix, that were told on the Overwatch forum and YouTube, and everywhere I could find an advice (I even tried a total reboot of my computer). In the end, it still gave me “rendering device has been lost”. So I searched further more on internet, and found an advice from Nvidia, here it is :

Open NVIDIA control Panel (Right click on desktop and click on NVIDIA control panel) > Go to Manage 3D settings, under 3D Settings > select Program Settings > Select app/game from the dropdown menu > if it is not listed in the dropdown menu then click Add then select the respective .exe to the list > And now change these settings from Option 2.

  • Power management mode - prefer maximum performance
  • Tripple buffering - Off
  • Threaded optimization - ON
  • vertical Sync - off

Apply these settings, refresh the Desktop several times, start the game play and check the performance

In case you get the same “access denied” as me when trying to apply the settings, try to open it as administrator, or try downloading the latest Nvidia driver, from Nvidia Driver Downloads. If you can’t find it, just send me a message and I’ll give you the link.

For now I haven’t had the issue again, I hope it will definitly fix it for me, and for everyone else :slight_smile:


#12

I’ve already tried these settings but the issue was still present. Is your gpu from the GeForce RTX series?


#13

Nop, mine is GeForce GTX, but I’ve had the issue for a month now.


#14

Are you overclocking at some point ? I’ve seen somewhere that if you’re overclocking you can get the issue.
And I’ll probably gonna sound dumb, because it seems that tried everything like me, are you sure that your computer isn’t overheating ? I saw that if it gets close to 90°C it can also do that.
But I’ll try to make other research to see if I can find something to help you. I know how annoying it can be. Lost 250 points in ranked because of that x)


#15

Nope, no overclocks. I’ve also monitored temps, neither my GPU nor my CPU goes above 70c.

As far as I know, there’s no know fix at the moment for the issue with people who have RTX cards . There’s a thread on the US forums with over 100+ replies and not a single one is able to play problem-less with RTX cards.

I feel like there’s some progress as currently I haven’t encountered the rendering device error, but the ‘Application encountered an unexpected error’ that I’ve mentioned in my reply before you posted with the Report ID. I’m waiting for a reply from the customer support as I suppose they have more info on what’s causing it.


#16

Well, I’ll cross my fingers for you in hope they find a way to fix this mess! :slight_smile:


#18

Update, I’m might have found another way, I uninstalled the 3D driver and the PhysX game support software from nvidia, since I only need the video and audio drivers.
I’ve found that fix on GeForce forum.


#19

I’ve experienced this issue before and here are my fixes that seemed to have worked:

Rolling back Windows 10 Update

Upon updating my latest windows version I was plagued with this error and the only fix seemed to be rolling back windows to the previous version, a version I’ve been on for almost a year now. That worked for me, but it may be too late for you.

RAM Replacement

A friend had this issue that later evolved into repeated crashes on almost every demanding game he played. Turns out after a year of investigation, it was a RAM issue.

Friend had to buy a new 8GB stick of RAM in order to play consistently and it solved the crashes on every game he had. Although the issue started with Overwatch crashing, it may not have been entirely related.

Hope this somewhat helps.


#20

The problem in here, is that there’s only one game that crashes constantly, and it’s Overwatch. I think I kind of found another solution, it seems that the game doesn’t Overlay, so I took off Windows, Twitch and Discord Overlay. I’m right now trying to see which one was making my game crash.


#21

Thanks. This solved my problem!