Battlenet server down for maintenance?

Same for me since patch 5 over a week ago.
Hope Blizzard will do an update soon so it will work

I have the same issue since the patch. I’ve tried some of the forum ideas for solutions to no avail. My Diablo III works fine. It is just with SCII.

1 Like

Hi everyone. I have exactly the same issue. I can play other games like Hearthstone, or the first Starcraft, but since last week, each time I start StarCraft II, after the “Authentication” message, I’m always getting this:

“Can’t Connect to Blizzard Services”

I have already tried every suggestion in the forums, but the problem remains.

1 Like

Even after 5.0.2 patch, the problem is still there :frowning:

1 Like

Same problem, even after another patch appeared to install. I thought I recalled reading a post or two about deleting a specific file which then had SCII working, but I can’t find the posts now.

1 Like

I am also having this issue.

1 Like

Same problem here, more than a week already. Can’t log in.


I’m having the same issue, every time I try to log in it gives me an error server is down for maintenance!

1 Like

same, dammit. This really sucks

After new patch update 5.02. still not working.

After new patch update 5.02. still not working

Got the same problem since one week “maintenance work”. Re-installed battlenet, cache delete, new IP/DNS, starting different Exe-Files won’t work. It seems all Exe files trying to start PTR as it tries to login into Realm “XX-07” but I can
t find a way to change it.


Can’t play either … I can play offline but when I load a game, the game try to connect again and I need to reboot the game …

1 Like

is there any solution to this yet, haven’t been able to log in even reinstalled and nothing. keeps saying server down for maintenance


I got help from Blizzard and now it´s working. First I flushed and renewed the DNS and after that I deleted and Blizzardentertainment on several folders on the computer. Then reinstalled. Now it´s working

It’s possible that an incorrect configuration with the DNS (Domain Name System) is causing some trouble with the connection. Here is a link that will detail how to flush the DNS to make sure everything gets set back up properly: https()://

If this persists, let’s try a clean reinstall of the Blizzard app:

  1. Open Control Panel.
  2. Click Uninstall a program.
  3. If is listed, right-click on Blizzard app and select Uninstall. If it’s not allowing you to uninstall, you can manually delete the folder (usually located in Program Files (x86)). If the Battlenet folder isn’t located on your computer and Windows still says the Blizzard app is installed, then this is a problem with the Windows registry. You can find steps on fixing that here:
  4. Next let’s delete the temporary files. To find those files, press Windows Key + R and type the following commands, pressing enter after each one to open the folder location. Delete the, Blizzard and Blizzard Entertainment folders in each location:
    • %APPDATA%
    • %TEMP%
  5. Reinstall the app from: https():// and run the installer over the old application
  6. Make sure you run as Admin: https():// and install onto the C drive if possible.
  7. Retest the Blizzard app

I have mine loading now, so it appears to be working again. I moved the Public Test.exe out of the Starcraft folder.


After I removed the “StarCraft II Public Test.exe” from the Starcraft folder, mine are loading, too.


Same for me, it’s working after have removed that file, Thanks ! :slight_smile:

1 Like

It worked.
Thank you :slight_smile:

1 Like