[Main Thread] Temporary Request Error - Jan 2024

Same problem, but for some reason i can create lobby only for Exodus 3 arcade…


Same here. Tried logging a ticket but can’t submit the form.

1 Like

same for me, cant find a fix

1 Like

I had the same problem, is there a solution ?

Hey all,

I saw the reports here and have raised it to the developers to check out. If we have anything more to share, we’ll post an update.

Two questions did come to mind. First, is this affecting all regions for Starcraft 2 or just the EU region? You can swap to another region by using the gear wheel next to the PLAY button in the Battle.net Application before launching the game. Note your progress is separate between regions. This would only be a test to know if this may be specific to a region or not.

The other question is I see mention that not all custom games are affected. Is this only with certain mods? Or is it also happening with default maps?


I have tried on NA and it is working fine there.

For EU it is also with custom games using normal maps. Though there is 1 or 2 maps that work fine when I tried.
I tried many different arcade and it doesnt work.

Also doesnt work to watch replays together.

1 Like

Yes EU servers are not working.

Switching region to NA makes it work so seems it is an issue with EU servers

For me it was “Greaystone ravine” that does not work on EU region but works in Americas region.

1 Like

Cannot create lobbies on EU servers. Works fine on US servers.


Happens with all maps. EU only. Also cant watch replays in party.

Hey all,

I’m hearing that some adjustments were needed that should help with this. Can we test if this is still occurring?

1 Like

it is still happening, no custom game, no melee map, only coop or vs AI

1 Like

My friend and I are experiencing this issue either. No one of us able to create a game.

Gloria in excelsis Deo.
Cannot creeate game in -->CUSTOM—>MEELE
There was a temporary problem with your request. Please try again later.
Edit: EU ERROR — – America no error

1 Like

I am experiencing this problem on European servers and it happens in some modes of certain maps.

1 Like

Hi there. Having the same issue on both my devices. I can’t create arcade lobbies, but melee ones work just fine. The problem started just today, never had it before. Switching to Asia seemed to have helped

upd: Fine on America too
upd2: My friend couldn’t make any lobbies, too, even with melee maps. But i was able to use melee maps.
upd3: Also i can’t rate maps which i have already played because i “have to play them once”, maybe this helps

Having the same issue, but switching region, turning on/off VPN (or VPNing to a different country) doesn’t help.

having the temporary error on custom melle maps to join saying i need to buy the game or upgrade it and if i want to start a lobby myself it says the error message.
Eu server, network reset, modem reset, game reinstaled and repaired multiple times with no results except wasting time.
can not even create a single player vs Ai match. mods or without mods. ladder maps/blizzard maps or any other non blizzard map. nothing works
Edit; the map Hecate is the only one working somehow

I am having same issues…

custom melee maps, mods, nothing working… not loading error pops up
there was temporary problem with your request
Not able top play SC2
EU Region.

At least Blizzard should acknowledge the global issue… and post a notification along with an ETA on the fix, so that we are not bombarding the forum, internet and support for with questions and asking for Help…

1 Like

I tried the same thing with 0 results…

1 Like

Same here. EU not working. NA working