[Main Thread] Temporary Request Error - Jan 2024

same issue, i can’t create or join custom melee!

Same issue here. Europe. Fresh windows install.

Same issue. The EXACT same custom map that works fine on NA server causes an error on EU server.

Same issue. Tried hosting Left 2 die map in Arcade, but got the error on EU server, works fine on NA server.

Same here, im almost saying some pc hacker from the goverment is behind this with the message stop playing games and save the world

Its been 2 days…

SC2 is not playable… neither any acknowledgement from Blizzard nor any word about resolution…

Their 5 months ols article on this issue suggests
If there is no Downtime notification or news exists anywhere… web/forum/twitter/X/Internet then its your problem not at our end…
do the following

Reset the network
Do a modem reset
Update the drivers
Reinstall or repair the game installation

So suddenly blizzard is having blind eye on the similar issue being faced by hundred’s of users across the world and points something is happening simultaneously on all the affected users???

Come on blizzard stop ZZzzzz wake up and resolve this issue…



Chill out dude… there are litterally 2 responses from blizzard devs in this very thread yesterday… so where does the “neither any acknowledgement from Blizzard” come from?
And I am sure it is not a trivial fix, since it is clearly not everyone that is affected, since lobbies are being made in the game(including for maps I personally can’t make/join myself), which makes it harder for them to diagnose the actual issue and test if their attempts at fixing it actually works. Yes this situation sucks, but at least be reasonable

1 Like

Man, I understand you, I even rebooted my PC,…3 times and wiped off the dust…
only this f Direct Strike works

Probably creators of Direct Strike hacked server to make other players play their kiddy game

Still glitchy. I don’t know if it connected somehow, but despite being able to create games on Asian or American servers. I have problems uploading mods using StarCraft 2 Editor for all three locations: EU, America, Asia. Therefore my results so far looks like this:

Download, create games:
EU - not working
America - OK
Asia - OK

Upload new files in Editor:
EU - not working
America - not working
Asia - not working

Blizzard, couldn’t you just rollback whatever you have released recently? We probably want the game to be at least playable. More than any features you brought with last update, whatever they may be. Don’t you think?

1 Like

Found a work around,
→ option 1: go to this path: “C:\ProgramData\Blizzard Entertainment\Battle.net\Cache” and delete everything.
→ option 2: exit SC2. Switch region to US, start SC2 and exit SC2. Switch region back to EU.
→ option 3: create a group with someone that can play, join lobby.
→ option 4: change the DNS on your network card to point to, for a more permanent fix

Didn’t work for me sadly :frowning:

Here’s some additional info:
Same map DID work earlier today and allowed me to host:
i.imgur. com/JRPN8U5.png

But a few hours later it did not:
i.imgur. com/qEzjBJ0.png

(Delete spaces before .com, had to add those because someone decided it’s a good idea to forbid links in a tech support forum)
I know EU has always been treated by Blizzard like a second-rate citizen, but seriously, It’s been three days. The least you could do is acknowledge the issue.

1 Like

The problem is fixed for me :smiley:

Bull$hit. 20 characters

The problem isn’t fixed. Come on, Blizzard, FOUR DAYS !!! REALLY ???
I will NEVER buy from you NOTHING!

1 Like

Have this issue as well for days. Some more info: Sporadically it ends up working. Another thing I noticed is that if you choose an offline game for the same map, it works.
Tried everything else, changed DNS servers, changed region etc. Nothing makes a difference, except an offline game vs AI

1 Like

This is honestly becoming seriously ridiculous. A modicum of responsibility for the functionality of a game you developed and are supposed to support would be in order, Blizzard. Or do you not give a rat’s ass?

1 Like

Updating that it is still occuring, for Starjeweled (the blizzard made mod) and Nexus Co-Op at least. Those are the Arcade games I regularly check and they work like 1% of the time, but 99% of the times I’m up this error shows up and they don’t.

buying the Legacy of the Void fixed it for me. No joke.
i could not create the arcade mode. Tried to join a lobby. Told me to “update” my starcraft-license. Legacy of the void was the campaign that i was missing. Bought it. Now i can join and create the lobby
Edit: Stopped working again the next day.